Crossfade: Nasty Error Notification Popup Window

Added by Mad Joe about 2 years ago

It's really annoying for a user to click "Close" each time the following message pops up:

Crossfading failed because the songs had different sample rates.  You can use the Sample Rate Converter to convert the songs to the same sample rate.

However, it's even more annoying if for some reason you're afk for some time and when you get back, there are dozens of identical error popups waiting you to close them!

I propose the following solution:
Let's try to remove those nasty popup notification windows, since there should be a nicer way to warn a user for this matter, eg. how about a nice tooltip that appears for 10 seconds above a bitrate, or even better - under the speaker icon within the panel bar?

Alternatively, you could add a checkbox element within the plugin settings: "Hide error messages".

Finally, is it possible now to suppress the error popup somehow?


Replies (3)

RE: Crossfade: Nasty Error Notification Popup Window - Added by John Lindgren about 2 years ago

Mad Joe wrote:

Finally, is it possible now to suppress the error popup somehow?

You can use the Sample Rate Converter to convert the songs to the same sample rate.

RE: Crossfade: Nasty Error Notification Popup Window - Added by Mad Joe about 2 years ago

You can use the Sample Rate Converter to convert the songs to the same sample rate.

I truly believe it's a huge overkill just for stopping a popup to show. I have thousands of songs and this is definitely NOT an option.

RE: Crossfade: Nasty Error Notification Popup Window - Added by Michael Schwendt almost 2 years ago

Definitely not? Why not? It adjusts the sample rate on-the-fly. Plugins > Effect > Sample Rate Converter

(1-3/3)