Bug #137

Unknown tuple field name "encoder" messages on console

Added by Hans de Goede over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:June 25, 2012
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:libaudtag
Target version:3.3
Affects version:3.3-alpha1

Description

When I start audacious (tried with both 3.2.3 and 3.3-alpha1) from a terminal, and play certain music albums the terminal fills with:
"Unknown tuple field name "encoder".
messages.

History

#1 Updated by John Lindgren over 4 years ago

certain music albums

What format? I also play "certain music albums" and don't see the problem ... :)

#2 Updated by Hans de Goede over 4 years ago

John Lindgren wrote:

certain music albums

What format? I also play "certain music albums" and don't see the problem ... :)

Certain mp3 albums:

[hans@shalem ~]$ id3info Music/Favorites/Imperia/The\ Ancient\ Dance\ of\ Qetesh/Imperia\ -\ 01\ -\ Awakening.mp3

  • Tag information for Music/Favorites/Imperia/The Ancient Dance of Qetesh/Imperia - 01 - Awakening.mp3 === TIT2 (Title/songname/content description): Awakening === TALB (Album/Movie/Show title): The Ancient Dance of Qetesh === TPE1 (Lead performer(s)/Soloist(s)): Imperia === TCON (Content type): Metal === TYER (Year): 2004 === TRCK (Track number/Position in set): 1/13 === TSSE (Software/Hardware and settings used for encoding): Audiograbber 1.83.01, LAME dll 3.98, VBR 3 (Default method), Stereo, Normal quality
  • mp3 info
    MPEG1/layer III
    Bitrate: 128KBps
    Frequency: 44KHz

A quick grep shows that the "encoder" tuple name gets set by either one of:
[hans@shalem master]$ grep -r encoder audacious-3.3-alpha1
audacious-3.3-alpha1/src/libaudtag/id3/id3v24.c: associate_string (tuple, -1, "encoder", data, size);
audacious-3.3-alpha1/src/libaudtag/id3/id3v22.c: associate_string (tuple, -1, "encoder", data, size);

And the error is caused by the " field_dict" dict in "src/libaudcore/tuple.c" not having an encoder entry.

#3 Updated by John Lindgren over 4 years ago

  • Category set to libaudtag
  • Target version set to 3.3
  • % Done changed from 0 to 100

#4 Updated by John Lindgren over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF