Bug #346

SDL error: Failed to open audio stream: XAudio2: XAudio2Create() failed at open..

Added by Benj Marchand over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:September 19, 2013
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/sdlout
Target version:3.4.2
Affects version:3.4.1

Description

Hi,

On windows 8 x64(with full updates), during the opening, this error message is displayed "SDL error: Failed to open audio stream: XAudio2: XAudio2Create() failed at open.."

In File > Preferences..., I can switch the ouput settings to "FileWriter Plugin" and this message is not anymore displayed.

But in both cases, the songs are played in 2 or 3 seconds. The audio volume is automatically switch off. No sound at all.

I tried the workaround from the forum "set SDL_AUDIODRIVER=DirectSound" (http://redmine.audacious-media-player.org/boards/1/topics/887), no issue at the opening but still at the playing.

Do you have any idea about this issue?

Thank you.

------------
Windows 8 x64 (with full updates)
Audacious 3.4.1 (not tested other)
Run from "C:\Program Files (x86)\Audacious\bin"

SDL2.dll (853.5 kB) John Lindgren, September 27, 2013 03:08

Associated revisions

Revision 94755b9a
Added by John Lindgren over 3 years ago

Note that SDL 2.0 must be built from source. Closes: #346.

Revision 602627d3
Added by John Lindgren over 3 years ago

Note that SDL 2.0 must be built from source. Closes: #346.

History

#1 Updated by John Lindgren over 3 years ago

  • Category changed from audtool to plugins/sdlout

I have no idea why this happens, and I can't reproduce it, but it seems that XAudio2 (or SDL's usage of it) is unreliable. So for the next Windows build I will probably rebuild SDL to use only DirectSound.

http://distfiles.audacious-media-player.org/audacious-3.4-win32.zip uses an older version of SDL. See if it works for you.

#2 Updated by Waikiki Tejada over 3 years ago

I'm having the same problems (namely, the SDL error when I try to play any audio file). My specs are the same as Benj's

  • Windows 8 x64
  • Audacious 3.4.1

The workaround posted at the forum works for me (I set the "SDL_AUDIODRIVER" environment variable to "DirectSound" in PowerShell, then run Audacious from within PowerShell).

John Lindgren wrote:

http://distfiles.audacious-media-player.org/audacious-3.4-win32.zip uses an older version of SDL. See if it works for you.

This version works fine.

#3 Updated by Benj Marchand over 3 years ago

Thank you for your prompt answers.

Version 3.4 works fine for me.

If you need debug/verbose log, don't hesitate to drop me instructions if that can help for the next release.

Thanks again.

#4 Updated by John Lindgren over 3 years ago

Please see whether 3.4.1 works with this alternate version of bin/SDL2.dll.

#5 Updated by Carlo Bramini over 3 years ago

Please see whether 3.4.1 works with this alternate version of bin/SDL2.dll.

This SDL2.DLL works fine, at least on my PC at home.

#6 Updated by Benj Marchand over 3 years ago

Hi John,

As for Carlo, your new file fixes this issue (the "SDL_AUDIODRIVER" variable is NOT set).

Thank you a lot!

#7 Updated by Waikiki Tejada over 3 years ago

The alternate version of SDL2.dll works on my side too.

#8 Updated by Ted Kritzler over 3 years ago

I was having the stream open issue as well, after having the program work fine for a couple of weeks after install. Replacing SDL2.dll fixed the issue.

#9 Updated by John Lindgren over 3 years ago

  • Status changed from New to Closed
  • Target version set to 3.4.2
  • % Done changed from 0 to 100

3.4.2 will include the fixed version of SDL2.dll.

Also available in: Atom PDF