Bug #380

Scrobbling fails when track number is not set

Added by Sylwester B about 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:December 11, 2013
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/scrobbler2
Target version:3.5
Affects version:3.4.3

Description

If any song don't have set id in album scrobbler send to last.fm irrcorect value trackNumber (set as -1) this situation make error :

main.c:532 [main]: Startup complete.
scrobbler_xml_parsing.c:11 [prepare_data]: Data received from last.fm:

<lfm status="failed">
<error code="6">
trackNumber must be a non negative integer
</error>
</lfm>

Associated revisions

Revision da5f962f
Added by John Lindgren almost 4 years ago

scrobbler2: Handle empty tuple fields correctly. Closes: #380.

History

#1 Updated by Luís Picciochi almost 4 years ago

I couldn't reproduce this. Do you confirm you are using the 3.5 (development) version?
Can you please show the output of a program like mp3info over the file in question?

mp3info track.mp3

Thanks.

#2 Updated by Sylwester B almost 4 years ago

mp3info make information :

does not have an ID3 1.x tag.

#3 Updated by Sylwester B almost 4 years ago

This output is bad because all my files have tags (incomplete but write standard data e.g track name, artist and album name) and Tracklist manager detect this tags when I refreshing or add new file

#5 Updated by John Lindgren almost 4 years ago

  • Subject changed from Irrcorrect send value trackNumber to Scrobbling fails when track number is not set
  • Status changed from New to Closed
  • Assignee deleted (Luís Picciochi)
  • Target version set to 3.5
  • % Done changed from 0 to 100
  • Affects version 3.4.3 added

Also available in: Atom PDF