Bug #546

Showing negative time elalsed on audio streaming in GTK interface

Added by Rafael Linux User over 2 years ago. Updated over 1 year ago.

Status:Closed Start date:May 27, 2015
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/gtkui
Target version:-
Affects version:3.6.1

Description

When listening shoutcast internet radio streaming, elapsed time is showing negative (preceded with a "minus" sign, like "-12:-20 / 00:00". This is only happening on listening radio streaming and with GTK interface (I know you will change to GTK, so maybe this bug have no importance in this transition.

Thank you

Associated revisions

Revision 1f6d630e
Added by John Lindgren about 2 years ago

gtkui: Fix display of negative remaining time. Closes: #546.

Revision ebc3b06a
Added by John Lindgren about 2 years ago

gtkui: Fix display of negative remaining time. Closes: #546.

History

#1 Updated by John Lindgren over 2 years ago

Please list exact steps to reproduce. I tried here, and saw playback start at 0:00 and count up.

#2 Updated by Rafael Linux User over 2 years ago

Well, the related issue is in OpenSUSE 13.2 with KDE 4.14. However, I'm in other OpenSUSE 13.2 with Plasma 5, and the issue is inexistent!!!!
On monday I will look again in my KDE 4.14 system.

Thank you

#3 Updated by John Lindgren over 2 years ago

Any news on this?

#4 Updated by Rafael Linux User about 2 years ago

The issue is not happening in Plasma 5, but still in KDE 4.

Sorry for make you wait my reply.

#5 Updated by John Lindgren about 2 years ago

  • Category set to plugins/gtkui
  • Status changed from New to Closed
  • Target version set to 64
  • % Done changed from 0 to 100

Fixed. It would have been helpful for you to indicate that you had enabled the Remaining Time option (View -> Show Remaining Time).

#6 Updated by Rafael Linux User about 2 years ago

Sorry John, I always change that option in Audacious, and was a long time modified, so I didn't take it into account.

Thank you for the fix.

;)

#7 Updated by John Lindgren over 1 year ago

  • Target version deleted (64)

Also available in: Atom PDF