Bug #605

Audacious starts up with visible artifacts

Added by Davyd McColl 6 months ago. Updated 5 months ago.

Status:Closed Start date:December 15, 2015
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:win32
Target version:3.7.1
Affects version:3.7

Description

When Audacious starts up on Windows, using the classic skins, I see artifacts on-screen. This only applies when the player remembers a prior shaded state. Please see attached screenshot -- I don't think I'm explaining it well. Applies to latest download at time of writing (3.7.2)

audacious-startup.png (6.8 kB) Davyd McColl, December 15, 2015 11:17

libgdk-win32-2.0-0.dll (672 kB) John Lindgren, December 24, 2015 12:37

Associated revisions

Revision 98e6173b
Added by John Lindgren 5 months ago

Add GTK+ patch to work around bug (?) in Win32 SetWindowPos. Closes: #605.

Revision 33bdd4ce
Added by John Lindgren 5 months ago

Add GTK+ patch to work around bug (?) in Win32 SetWindowPos. Closes: #605.

History

#1 Updated by John Lindgren 5 months ago

  • Target version deleted (3.7.1)
  • Affects version 3.7 added

It appears to be a bug in GTK+ on Windows. If you find a fix, I'd be happy to include it. Otherwise, this will eventually be fixed by the Qt port.

Also, please stop talking about versions that don't exist. 3.7 is the newest. There is no 3.7.1 or 3.7.2 yet.

#2 Updated by Davyd McColl 5 months ago

Also, please stop talking about versions that don't exist. 3.7 is the newest. There is no 3.7.1 or 3.7.2 yet.

Apologies -- I keep on getting muddled between the 3.6.x releases and 3.7 ):

I will try to build on Windows at some point -- I'd love to be more than just a bug reporter. I'm not a GTK guru though, so I wouldn't hold my breath for a useful patch from me ):

#3 Updated by John Lindgren 5 months ago

I looked into this further and it appears to be actually due to a bug/undocumented feature of the Win32 API function SetWindowPos. Incidentally, the problem isn't reproducible under Wine, only actual Windows. It's possible to work around it in GTK+. I'm attaching a patched DLL which fixes the problem for me.

#4 Updated by John Lindgren 5 months ago

#5 Updated by Davyd McColl 5 months ago

Excellent! Thanks! I'll give this a go when I reboot tonight (:

#6 Updated by Davyd McColl 5 months ago

This patched libgdk seems to do the trick for me (: Thanks for the time and effort to track the issue down and work around it (:

#7 Updated by John Lindgren 5 months ago

  • Status changed from New to Closed
  • Target version set to 3.7.1
  • % Done changed from 0 to 100

Also available in: Atom PDF