Bug #615

Audacious crashes on missing .wvc files for hybrid wavpack files

Added by Roman Pauer about 1 year ago. Updated about 1 year ago.

Status:Closed Start date:January 10, 2016
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/wavpack
Target version:3.7.2
Affects version:3.6, 3.7

Description

Audacious crashes whenever it attempts to play hybrid Wavpack file without .wvc file.
The bug was introduced in GitHub commit ae0cdf6a98dc7dc91d6156d07a62b0a2f3d8479d (Use VFSFile member functions. - https://github.com/audacious-media-player/audacious-plugins/commit/ae0cdf6a98dc7dc91d6156d07a62b0a2f3d8479d ).
The problem is in function wv_attach (in file wavpack.cc) - when calling WavpackOpenFileInputEx, the 3rd parameter should be nullptr if the .wvc file is not available.

Associated revisions

Revision 74d6a28b
Added by John Lindgren about 1 year ago

wavpack: Fix crash if .wvc file doesn't exist. Closes: #615.

Revision 8041179e
Added by John Lindgren about 1 year ago

wavpack: Fix crash if .wvc file doesn't exist. Closes: #615.

History

#1 Updated by John Lindgren about 1 year ago

  • % Done changed from 0 to 100
  • Target version set to 3.7.2
  • Status changed from New to Closed

Nice work debugging this! Fixed.

Also available in: Atom PDF