Bug #91

Jump to song search results do not include songs not yet scanned for metadata

Added by carlos lopez almost 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:March 31, 2012
Priority:Major Due date:
Assignee:- % Done:

100%

Category:libaudgui
Target version:3.2.3
Affects version:3.2.2

Description

Items on queue list are not indexed by the search engine filter until metadata is read

Steps to reproduce:

  • Options->Preferences->Playlist
    • Mark "Do not load metadata for songs until played"
  • Close audacious
  • Open with audacious a ramdom directory containing several mp3 files
  • Try to search some files (pressing j)

Actual result: All files show on the jump to song dialog but no matter what you type on the search filter, it will ignore all file which metadata was still not read (all in this case)
Expected result: All files show on the jump to song dialog and the search filter is able to "grep" them using the directory/filename information until the metadata information can be added.

The same happens with audtty ncurses GUI.

I am using audacious 3.2.1 on Debian/sid

Associated revisions

Revision 32c13a65
Added by John Lindgren almost 5 years ago

Make jump to track work even if songs are not scanned yet. Closes: #91.

Revision 5aa14dd2
Added by John Lindgren almost 5 years ago

Make jump to track work even if songs are not scanned yet. Closes: #91.

History

#1 Updated by John Lindgren almost 5 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Items on queue list are not indexed by the search engine until metadata is read to Allow searching by path/filename in search tool

Currently the search tool only searches by metadata. This is the intended behavior, not a bug.

#2 Updated by John Lindgren almost 5 years ago

  • Category deleted (core)

#3 Updated by John Lindgren almost 5 years ago

  • Category set to plugins/search tool
  • Affects version added

#4 Updated by carlos lopez almost 5 years ago

John Lindgren wrote:

Currently the search tool only searches by metadata. This is the intended behavior, not a bug.

I don't think this is true. Once audacious has read the file metadata and it indexes it, I can just search for it on the jump to song dialog using the directory or file-name (any part of the path) and it just works.

#5 Updated by John Lindgren almost 5 years ago

carlos lopez wrote:

John Lindgren wrote:

Currently the search tool only searches by metadata. This is the intended behavior, not a bug.

I don't think this is true. Once audacious has read the file metadata and it indexes it, I can just search for it on the jump to song dialog using the directory or file-name (any part of the path) and it just works.

You are confusing the search tool and the jump to song dialog. They are different.

#6 Updated by carlos lopez almost 5 years ago

Didn't know about any search tool other than the "jump to song" dialog.

I was talking all this time about the "jump to song" dialog (I am using winamp-like interface)

#7 Updated by John Lindgren almost 5 years ago

  • Category deleted (plugins/search tool)

#8 Updated by John Lindgren almost 5 years ago

  • Tracker changed from Feature to Bug
  • Subject changed from Allow searching by path/filename in search tool to Jump to song search results do not include songs not yet scanned for metadata
  • Category set to libaudgui
  • Status changed from New to Closed
  • Target version set to 3.2.3
  • % Done changed from 0 to 100
  • Affects version 3.2.2 added

Also available in: Atom PDF