Bug #99

Help! Equalizer Presets don't survive app restart

Added by Steve DeMarco over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:April 13, 2012
Priority:Major Due date:
Assignee:- % Done:

100%

Category:plugins/skins
Target version:3.2.3
Affects version:3.2.2

Description

I built Audacious 3.2.2 on my Compaq Presario v4000 laptop running Puppy Lucid 5.2.8 w/ 2.6.33.2 kernel. Everything works and sounds great, except for one major problem that's driving me nuts. I am using the a winamp 2.x skin so that I can import and have access to the standard winamp eq settings that I've used and enjoyed in past versions of Audacious. But no matter how I try to import them with 3.2.2 they don't survive a restart of Audacious. Poof they're gone!

Here's the methods I have tried:
1. Following the instructions found here--> http://www.mytechguide.org/8210/how-to-import-winamp-equalizer-preset-into-linux-audio-players-like-audacious-xmms-etc/ I put the attached eq.preset file into ~/.config/audacious, and then hitting the "Presets" button on the equalizer gui, I did a "Load->From file" which brought up the "Load Equalizer Preset" window. From there I pointed it to my eq.preset file and hit Open. Then back to the Preset button to try a "Load->Preset", but the Presets list is empty...!? This worked fine with my previous version of Audacious 2.5.4. Am I doing something wrong? I thought just putting the eq.preset file in the ~/.config/audacious folder was all you needed to do so that audacious could see the settings.
2. I have also tried importing the winamp eqf files via "Presets->Import->WinAMP Presets". But when I get to the "Load Equalizer Preset" window I can only import 1 eqf file at a time, not the whole folder of presets. If I import these one by one, they actually do show up in the Presets window if I do a "Load->Preset" named something like "Entry1". Then I can do a "Presets->Save->Preset" which allows me to change the name to something like "Classical" or "Soft Rock" whichever is appropriate. So I can do this one by one (very tedious) and eventually get all the presets loaded and renamed to show up in the Presets list when I do a "Load->Preset". Seems great. But if I close Audacious and restart...POOF! they're all gone and I'm back to square one. I've tried "Presets->Save->To File" and "Presets->Save->To WinAMP EQF file", but that only allows you to save one preset at a time (not the whole lot), and worst of all, when you shut down Audacious and restart it the "Load Presets" window is blank again. As I stated previously, importing and saving the winamp presets worked perfectly with versions 2.4.0 and 2.5.4 versions of Audacious. I love this program, but this eq thing is driving me crazy. Can someone please help me? Thank you kindly for any advice...

-Steve D

eq.preset - This file contains all the standard winamp eq presets (311 Bytes) Steve DeMarco, April 13, 2012 20:25

winamp-eqf-files.7z - This file contains the same files in winamp eqf format (803 Bytes) Steve DeMarco, April 13, 2012 20:25

Associated revisions

Revision b56646c0
Added by John Lindgren over 5 years ago

skins: Fix equalizer presets being lost on startup. Closes: #99.

Revision c637fccf
Added by John Lindgren over 5 years ago

skins: Fix equalizer presets being lost on startup. Closes: #99.

History

#1 Updated by John Lindgren over 5 years ago

  • % Done changed from 0 to 100
  • Target version set to 3.2.3
  • Status changed from New to Closed
  • Category set to plugins/skins
  • Affects version 3.2.2 added

Also available in: Atom PDF