Project

General

Profile

upload files from nautilus

Added by Darío Rozalén 4 months ago

Hello everyone, I usually put music in the following way: I navigate through my folders with nautilus, I enter the one I want, I select several music files and I give "enter (intro)".
Well, the problem comes because Audacius only plays one of the songs, usually the last one. Sometimes I put the tail all the list and start playing the first (which is what I understand what to do), but usually only plays one. I do not get it.
Does anyone know how I can solve this ????
Thank you.


Replies (5)

RE: upload files from nautilus - Added by John Lindgren 4 months ago

Try opening the files in Audacious from a terminal window (e.g. "audacious file1 file2 ..."). If that works correctly, then you need to ask for help from GNOME to figure out what Nautilus is doing differently.

If you still have a problem opening the files from a terminal window, then let us know if you see any errors in the terminal, and we can try to help you from there.

RE: upload files from nautilus - Added by Darío Rozalén 4 months ago

Hello and thanks for answering.
The problem is gnome, I think. In fact it only happens if the application is defined as the default application (select and press enter), if I put rhytmin box as the default application and open some files with "open with ..." and select Audacius, it works fine. But if I put Audacius as the default application, I select and press enter, then it does not go well.
Also, I checked from the terminal and it works perfectly.
That is, the following error appears in the terminal: Failed to load module "canberra-gtk-module". But it's fine.

If you can help me thank you, and if not also. I will ask in a more generic forum.

RE: upload files from nautilus - Added by John Lindgren 4 months ago

Okay, it looks like it's a known bug in Nautilus:
https://gitlab.gnome.org/GNOME/nautilus/issues/117

I won't go into my general dissatisfaction with GNOME here, but you could try using one of the more "conservative" forks of Nautilus, like Linux Mint's Nemo. That's what I'm currently using, and it doesn't seem to suffer from the same bug.

RE: upload files from nautilus - Added by Darío Rozalén 4 months ago

thank you
Now I have a clearer problem: "Open" and "Open with ..." work differently for some strange reason.
I have looked at the link that you put, but the truth is that it is not very clear to me. Can you fix it? How?

RE: upload files from nautilus - Added by John Lindgren 4 months ago

Darío Rozalén wrote:

Can you fix it? How?

No. It's a bug in Nautilus. We can't fix it.

    (1-5/5)