Project

General

Profile

Bug #1062

Audacious broke dpkg trying to upgrade to 4.1.0 (from 4.0.5)

Added by Kitty Linux about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Major
Assignee:
-
Category:
libaudqt
Start date:
February 05, 2021
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

I'm using Linux Mint 20 and PPA version of Audacious (ubuntuhandbook1/apps)
When I just use the command sudo apt upgrade, I got really weird error:

E: Sub-process /usr/bin/dpkg returned an error code (1)

And here's full output (only audacious part) after using sudo apt upgrade

 ...
Preparing to unpack .../2-audacious-plugins_4.1-0build2~ubuntu20.04_amd64.deb ..
.
Unpacking audacious-plugins:amd64 (4.1-0build2~ubuntu20.04) over (4.0.5-0build1~
ubuntu20.04) ...
Preparing to unpack .../3-audacious-plugins-data_4.1-0build2~ubuntu20.04_all.deb
 ...
Unpacking audacious-plugins-data (4.1-0build2~ubuntu20.04) over (4.0.5-0build1~u
buntu20.04) ...
Preparing to unpack .../4-audacious_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking audacious (4.1-0build4~ubuntu20.04) over (4.0.5-0build1~ubuntu20.04) .
..
Preparing to unpack .../5-libaudcore5_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking libaudcore5:amd64 (4.1-0build4~ubuntu20.04) over (4.0.5-0build1~ubuntu
20.04) ...
Selecting previously unselected package libaudgui5:amd64.
Preparing to unpack .../6-libaudgui5_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking libaudgui5:amd64 (4.1-0build4~ubuntu20.04) ...
Selecting previously unselected package libaudqt2:amd64.
Preparing to unpack .../7-libaudqt2_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking libaudqt2:amd64 (4.1-0build4~ubuntu20.04) ...
dpkg: error processing archive /tmp/apt-dpkg-install-HLOpBR/7-libaudqt2_4.1-0bui
ld4~ubuntu20.04_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libaudqt.so.2', which is also in
 package libaudqt5:amd64 4.0.5-0build1~ubuntu20.04
Preparing to unpack .../8-libaudtag3_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking libaudtag3:amd64 (4.1-0build4~ubuntu20.04) over (4.0.5-0build1~ubuntu2
0.04) ...
Preparing to unpack .../9-code_1.53.0-1612368357_amd64.deb ...
Unpacking code (1.53.0-1612368357) over (1.52.1-1608136922) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-HLOpBR/7-libaudqt2_4.1-0build4~ubuntu20.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

with an option --fix-broken didn't help at all.

$ sudo apt install --fix-broken
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libaudqt5
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libaudqt2
The following NEW packages will be installed:
  libaudqt2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
9 not fully installed or removed.
Need to get 0 B/125 kB of archives.
After this operation, 499 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 462454 files and directories currently installed.)
Preparing to unpack .../libaudqt2_4.1-0build4~ubuntu20.04_amd64.deb ...
Unpacking libaudqt2:amd64 (4.1-0build4~ubuntu20.04) ...
dpkg: error processing archive /var/cache/apt/archives/libaudqt2_4.1-0build4~ubu
ntu20.04_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libaudqt.so.2', which is also in
 package libaudqt5:amd64 4.0.5-0build1~ubuntu20.04
Errors were encountered while processing:
 /var/cache/apt/archives/libaudqt2_4.1-0build4~ubuntu20.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I think it's because of trying to install new package over existing package on same path and that's why. Why not just upgrade existing package instead of new package?

History

#1 Updated by Thomas Lange about 1 month ago

  • Status changed from New to Rejected

Duplicate of #1060, this is not an issue on our side. Please report this to the PPA maintainer.

Also available in: Atom PDF