Project

General

Profile

Bug #1083

Fluidsynth chorus and reverb settings don't work

Added by Mostar Jam 69 about 1 month ago. Updated 24 days ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/amidi-plug
Start date:
April 02, 2021
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

Note: this issue affects both versions 3.1 in the official Ubuntu 20.04 repository and 4.1 in the ppa

This has been an ongoing issue for the versions of Audacious I've used on Ubuntu 20.04 and derivatives (like Pop OS), and I'm not sure how to fix it but I know where the issue is. The chorus and reverb settings don't work, and in the settings of AMIDI plugin when I attempt to override the settings, when I press play on a selected midi file the following gets printed to the terminal:

fluidsynth: error: Unknown string setting 'synth.reverb.active'
fluidsynth: error: Unknown string setting 'synth.chorus.active'

The issue is in https://github.com/audacious-media-player/audacious-plugins/blob/master/src/amidiplug/backend-fluidsynth/b-fluidsynth.cc with the following lines of code (lines 57 - 76):

int gain = aud_get_int ("amidiplug", "fsyn_synth_gain");
int polyphony = aud_get_int ("amidiplug", "fsyn_synth_polyphony");
int reverb = aud_get_int ("amidiplug", "fsyn_synth_reverb");
int chorus = aud_get_int ("amidiplug", "fsyn_synth_chorus");
if (gain != -1)
fluid_settings_setnum (sc.settings, "synth.gain", gain / 10.0);
if (polyphony != -1)
fluid_settings_setint (sc.settings, "synth.polyphony", polyphony);
if (reverb  1)
fluid_settings_setstr (sc.settings, "synth.reverb.active", "yes");
else if (reverb 0)
fluid_settings_setstr (sc.settings, "synth.reverb.active", "no");
if (chorus  1)
fluid_settings_setstr (sc.settings, "synth.chorus.active", "yes");
else if (chorus 0)
fluid_settings_setstr (sc.settings, "synth.chorus.active", "no");

The gain and polyphony settings work just fine, but I'm not sure why the chorus and reverb settings don't. I don't believe this is just an issue with me, as I've used various installs of audacious on multiple computers running some variant of Ubuntu 20.04. This was not an issue with prior versions of Ubuntu such as 18.04, but I forget what version of Audacious was in the Ubuntu repository for that release. If this issue could be investigated, or if I'm doing something wrong, any assistance would be appreciated. I don't have enough experience with the fluidsynth API to be able to fix this myself.=

History

#2 Updated by John Lindgren 24 days ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

Also available in: Atom PDF