Project

General

Profile

Support #1107

ReplayGain support for MP3

Added by Damian Höster about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Major
Assignee:
-
Category:
-
Start date:
June 08, 2021
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

ReplayGain metadata in MP3s is currently not recognized by Audacious.

History

#1 Updated by John Lindgren about 2 months ago

  • Tracker changed from Feature to Support

ReplayGain certainly is supported for MP3 -- I use it just about every day.

Please attach an example of an MP3 file that isn't working for you.

#2 Updated by Damian Höster about 2 months ago

John Lindgren wrote:

ReplayGain certainly is supported for MP3 -- I use it just about every day.

Please attach an example of an MP3 file that isn't working for you.

Yes, you are correct. I was wrong. Both track and album ReplayGain is completely supported for MP3 by Audacious.

Problem was probably that SoundKonverter only added per-track ReplayGain metadata for MP3, which I didn't expect. So, not an Audacious issue.

#3 Updated by John Lindgren about 2 months ago

  • Status changed from New to Closed

Okay. Glad you found the issue. I'll go ahead and close this.

#4 Updated by Damian Höster about 1 month ago

There actually is a serious problem with ReplayGain metadata in MP3:

APE ReplayGain metadata in MP3 is not recognized by Audacious if any ID3 tags are present.

This is a big problem because
1. The vast majority MP3 files contain ID3 metadata and
2. Mp3gain writes APE ReplayGain metadata by default, and so does SoundKonverter.

I only could not reproduce the problem in my test because I removed all metadata from the file before reapplying ReplayGain.

#5 Updated by Damian Höster about 1 month ago

Opened a new ticket for this, bug #1115

Also available in: Atom PDF