Project

General

Profile

Bug #124

A declared dependency version of cdaudio-ng seem to be incorrect

Added by Luís Picciochi about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
plugins/cdaudio
Start date:
June 10, 2012
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

The configure.ac file states that the minimum required version of libcdio is 0.70, but when compiling, the cdio/cdio_unconfig.h file seems to be needed.
This file is not available at least until version 0.81 of the libcdio-dev package (in Debian). After installing version 0.83, everything went fine.

Attached is additional info on what I saw when trying to compile and what I did to fix it.
Also attached is a simple patch to fix this issue. I only increased the requirement for the relevant dependency. Probably the other, libcd*-related ones should also be increased but I'm not sure of that.

Best regards,
Pitxyoki

log (2.79 KB) log Luís Picciochi, June 10, 2012 02:55
config_cdaudio_ng.patch (519 Bytes) config_cdaudio_ng.patch Luís Picciochi, June 10, 2012 02:55

History

#2 Updated by John Lindgren about 9 years ago

  • Category set to plugins/cdaudio
  • % Done changed from 0 to 100

Also available in: Atom PDF