Project

General

Profile

Bug #169

Fix setting CPPFLAGS/LIBS in audacious-plugins autoconf script

Added by Brad Smith about 7 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
August 24, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

The audacious-plugins autoconf script currently sets up CPPFLAGS/LIBS with the
flags from Audacious very early in the script and polluting the environment
which causes some of the autoconf checks to potentially fail. So move setting
CPPFLAGS/LIBS to the very end so as to not pollute the environment but still
provide the flags for the build.

aud-configure2.diff (613 Bytes) aud-configure2.diff Brad Smith, August 24, 2012 10:56

History

#1 Updated by John Lindgren about 7 years ago

How would Audacious CPPFLAGS/LIBS cause autoconf checks to fail?

#2 Updated by Brad Smith about 7 years ago

John Lindgren wrote:

How would Audacious CPPFLAGS/LIBS cause autoconf checks to fail?

This line near the very top of the autoconf script...
LIBS="$LIBS $AUDACIOUS_LIBS"

adds libaudclient and libaudgui to LIBS which brings in those libraries and a whole slew of dependencies from them which is then polluting the linking environment for the autoconf tests. There is no reason these libs should be added like this so early on. Move them to the very end after running all of the autoconf checks.

#3 Updated by John Lindgren about 7 years ago

You haven't answered my question.

#4 Updated by John Lindgren about 7 years ago

  • Status changed from New to Rejected

Closing, not a bug.

Also available in: Atom PDF