Project

General

Profile

Bug #221

Cairo spectrum plugin high CPU usage

Added by zz top about 8 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
plugins/cairo spectrum
Target version:
-
Start date:
November 29, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

During playback, Audacious' CPU usage is around 8% on my machine and X11's is around 10%. When enabling the cairo spectrum plugin, they go up to 9% and 45%, respectively.

In version 3.3.1, the CPU usage was normal with the spectrum analyzer enabled.

History

#1 Updated by John Lindgren about 8 years ago

  • Status changed from New to Rejected

On my system:

                         Audacious  X
Without Cairo spectrum:  7.6%       4.9%
With Cairo spectrum:     8.3%       5.0%

Also, there were no changes made to the Cairo spectrum plugin between 3.3.1 and 3.3.2.

I suggest you look elsewhere for the cause of the high CPU usage. If you are using a compositing window manager, disabling that would be a good place to start.

Also available in: Atom PDF