Project

General

Profile

Bug #248

PKG_INSTALLDIR not present in pkg-config < 0.27

Added by szymon krasuski almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Major
Assignee:
-
Category:
core
Target version:
Start date:
February 02, 2013
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

after a recent git pull ( configure.ac | 2 ++ ) trying to compile: sh ./autogen.sh*info* running aclocal (-I m4)
info running autoheader
info running autoconf
configure.ac:26: error: possibly undefined macro: PKG_INSTALLDIR
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
error autoconf failed. (exit code = 1)

History

#1 Updated by John Lindgren almost 7 years ago

What version of pkg-config do you have?

#2 Updated by szymon krasuski almost 7 years ago

0.26-1ubuntu1 @12.04 LTS. for now commenting out 26th line #PKG_INSTALLDIR works

#3 Updated by John Lindgren almost 7 years ago

  • Subject changed from recent git pull caused this to PKG_INSTALLDIR not present in pkg-config < 0.27

#4 Updated by John Lindgren almost 7 years ago

nenolod is checking whether there's a way to allow the use of PKG_INSTALLDIR only with pkg-config >= 0.27. If not, we will have to revert commit 7c714a85 for the time being.

Also available in: Atom PDF