Project

General

Profile

Bug #426

Scrobbler spams feed when ID3 parser errors occur

Added by Chris Gahan over 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
April 06, 2014
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

It seems that when Audacious encounters a certain kind of ID3 parse error, it updates the track information many many times, causing the scrobbler plugin to submit the same track hundreds of times in a row (eg: my last.fm account shows 17,000 scrobbles of a track which I've listened to a few hundred times.)

Here's a track which causes the problem: http://chris.ill-logic.com/files/Pigbag%20-%20Papas%20Gotta%20Brand%20New%20Bag.mp3

Here's what my last.fm feed looks like: http://chris.ill-logic.com/images/audacious-overscrobbling.png

Here's what Audacious prints to the console after loading the track:

Entity: line 7: parser error : Char 0xFFFE out of allowed range
        <album corrected="0">￾一椀渀樀愀 䌀甀琀猀㨀 夀漀甀 
                             ^
Entity: line 7: parser error : PCDATA invalid Char value 65534
        <album corrected="0">￾一椀渀樀愀 䌀甀琀猀㨀 夀漀甀 
                             ^
Entity: line 7: parser error : Char 0xFFFE out of allowed range
        <album corrected="0">￾一椀渀樀愀 䌀甀琀猀㨀 夀漀甀 
                             ^
Entity: line 7: parser error : PCDATA invalid Char value 65534
        <album corrected="0">￾一椀渀樀愀 䌀甀琀猀㨀 夀漀甀 
                             ^
Entity: line 7: parser error : Char 0xFFFE out of allowed range
        <album corrected="0">￾一椀渀樀愀 䌀甀琀猀㨀 夀漀甀 
                             ^
Entity: line 7: parser error : PCDATA invalid Char value 65534
        <album corrected="0">￾一椀渀樀愀 䌀甀琀猀㨀 夀漀甀 
                             ^
Entity: line 7: parser error : Char 0xFFFE out of allowed range
        <album corrected="0">￾嬀䴀䔀䜀䄀䴀䤀匀䌀崀</album>
                             ^
[...240 lines of this...]

History

#1 Updated by John Lindgren over 5 years ago

I can't reproduce this at all; the example MP3 file is scrobbled just once for me. As a side note, the "parser error" is referring to an XML parser (last.fm API uses a lot of XML), not an ID3 parser.

#2 Updated by John Lindgren about 5 years ago

  • Status changed from New to Rejected

Not enough information to reproduce. Closing.

Also available in: Atom PDF