Project

General

Profile

Bug #482

audacious plugins does not find audacious in its default install location

Added by il lumilore almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
November 28, 2014
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

After installing audacious to the default /usr/local/bin, when configuring audacious-plugins, it will fail due to it not checking in that directory:
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for AUDACIOUS... no
configure: error: Cannot find Audacious 3.5; have you installed Audacious yet?

config.log (38.9 KB) config.log aud il lumilore, November 29, 2014 00:43
config.log (36.5 KB) config.log aud il lumilore, November 29, 2014 00:44

History

#1 Updated by John Lindgren almost 5 years ago

Please answer the following questions:
1. What OS and OS version?
2. What version of Audacious is this really? 3.5.3 does not exist yet.
3. Value of $PKG_CONFIG_DIR
4. Exact flags passed to ./configure (audacious and audacious-plugins)
5. Output of $ find /usr -name glib-2.0.pc
6. Output of $ find /usr -name audacious.pc

#2 Updated by John Lindgren almost 5 years ago

Correction: $PKG_CONFIG_PATH, not $PKG_CONFIG_DIR.

#3 Updated by John Lindgren almost 5 years ago

Also attach config.log for audacious and audacious-plugins.

#4 Updated by il lumilore almost 5 years ago

1. Opensuse 13.2 x64
2. 3.5.2 from http://audacious-media-player.org/download
3 echo $PKG_CONFIG_PATH returns nothing, so audacious doesn't seem to set it right. I also tried setting it manually to /usr/local/lib64/pkgconfig (which is still a blank directory after make install ing audacious, but that didn't help.
4. it happened with no flags passed to audacious and audacious-plugins and with --prefix=/usr/local/ on audacious plugins
5 $ find /usr -name glib-2.0.pc
/usr/lib64/pkgconfig/glib-2.0.pc
find: ‘/usr/NX/var/log/nxnode/C-spock.site-1001-FB8C466D686F2913B2C739AECF301572’: Permission denied
find: ‘/usr/NX/var/log/nxnode/F-C-spock.site-1001-AFCC5B08E51E6AC4388BB6FB7CC02D33’: Permission denied
find: ‘/usr/NX/var/db/failed’: Permission denied
find: ‘/usr/NX/var/db/closed’: Permission denied
find: ‘/usr/NX/var/db/running’: Permission denied
find: ‘/usr/NX/var/db/node/externalports’: Permission denied
find: ‘/usr/local/include/libaudgui’: Permission denied
find: ‘/usr/local/include/libaudcore’: Permission denied
find: ‘/usr/local/include/audacious’: Permission denied
find: ‘/usr/local/lib64/pkgconfig’: Permission denied
find: ‘/usr/local/share/locale’: Permission denied
find: ‘/usr/local/share/icons’: Permission denied
find: ‘/usr/local/share/audacious’: Permission denied
find: ‘/usr/local/share/man’: Permission denied
find: ‘/usr/local/share/applications’: Permission denied
find: ‘/usr/share/polkit-1/rules.d’: Permission denied

$ find /usr -name audacious.pc
find: ‘/usr/NX/var/log/nxnode/C-spock.site-1001-FB8C466D686F2913B2C739AECF301572’: Permission denied
find: ‘/usr/NX/var/log/nxnode/F-C-spock.site-1001-AFCC5B08E51E6AC4388BB6FB7CC02D33’: Permission denied
find: ‘/usr/NX/var/db/failed’: Permission denied
find: ‘/usr/NX/var/db/closed’: Permission denied
find: ‘/usr/NX/var/db/running’: Permission denied
find: ‘/usr/NX/var/db/node/externalports’: Permission denied
find: ‘/usr/local/include/libaudgui’: Permission denied
find: ‘/usr/local/include/libaudcore’: Permission denied
find: ‘/usr/local/include/audacious’: Permission denied
find: ‘/usr/local/lib64/pkgconfig’: Permission denied
find: ‘/usr/local/share/locale’: Permission denied
find: ‘/usr/local/share/icons’: Permission denied
find: ‘/usr/local/share/audacious’: Permission denied
find: ‘/usr/local/share/man’: Permission denied
find: ‘/usr/local/share/applications’: Permission denied
find: ‘/usr/share/polkit-1/rules.d’: Permission denied

#5 Updated by il lumilore almost 5 years ago

that last config was audacious-plugins, this one is audacious

#6 Updated by il lumilore almost 5 years ago

Also, on opensuse only 3.4.2 is the highest audacious that is available for it, and that one's system tray plugin (status icon) doesn't work with plasma 5. Does 3.5.2's systray plugin work with plasma5's systray?

#7 Updated by John Lindgren almost 5 years ago

  • Status changed from New to Rejected
  • Affects version deleted ()

It appears that your umask was set too restrictively when you installed audacious, hence the folders created are not readable as a normal user. Fix your umask and try again. Not a bug.

#8 Updated by John Lindgren almost 5 years ago

il lumilore wrote:

Also, on opensuse only 3.4.2 is the highest audacious that is available for it, and that one's system tray plugin (status icon) doesn't work with plasma 5. Does 3.5.2's systray plugin work with plasma5's systray?

No, Plasma 5 has dropped support for traditional status icons and uses a newer protocol which Audacious has no plugin for. So far you are the first to express interest in such a plugin. However I expect that one will be written eventually since the existing plugin uses GTK2 and therefore does not work with the Qt interface.

#9 Updated by il lumilore almost 5 years ago

Can you at least change the feedback so it mentions setting the PKG_CONFIG_PATH to where audacious is at that point? I noticed it said to do that for other things it couldn't find.

#10 Updated by John Lindgren almost 5 years ago

il lumilore wrote:

Can you at least change the feedback so it mentions setting the PKG_CONFIG_PATH to where audacious is at that point? I noticed it said to do that for other things it couldn't find.

That will make absolutely no difference if you have no read permissions on that folder.

Also available in: Atom PDF