Project

General

Profile

Feature #513

Option to disable ${artist} and ${album} falling back on folder names

Added by Zane Tu almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
libaudcore
Target version:
Start date:
March 03, 2015
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

In Audaciuos v3.6 that I installed from deb-multimedia.org [1], if a music file has no meta info, the name of its parent / grandparent folder will be used as ${artist} / ${album}.

For example, given the custom display string "${?title:${title}}${?artist: - ${artist}}", the file "/music/AVeryLongFolderName/FileWithoutMetaInfo - ArtistName.m4a" would be displayed as "FileWithoutMetaInfo - ArtistName - AVeryLongFolderName" in playlist, where " - AVeryLongFolderName" is undesirable. By contrast, Audacious v3.5.2 only shows "FileWithoutMetaInfo - ArtistName".

For those who really need the fallback behavior, you can add something like ${artistOrParentFolder} or ${albumOrGrandparentFolder}.

[1] http://www.deb-multimedia.org/dists/unstable/main/binary-amd64/package/audacious

History

#1 Updated by Zane Tu almost 3 years ago

I forgot to mention that the issue happens in "Winamp Classic Interface". In "GTK interface", this issue is less annoying because "Artist" and "Album" have dedicated columns.

#2 Updated by John Lindgren almost 3 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from [Audaciuos v3.6] ${artist} and ${album} should not fall back on folder names. to Option to disable ${artist} and ${album} falling back on folder names
  • Category set to libaudcore

The fallback behavior is intentional, hence not a bug, but we can add an option to disable it in the next version.

Also available in: Atom PDF