Project

General

Profile

Bug #664

Wrong track length displayed

Added by Not My Real Name about 5 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Start date:
September 10, 2016
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Audacious 3.7.2 seems to display wrong track lengths for some songs. However, it does read them to the end, leading to weird times like 16:00/3:51. In comparison, VLC shows the correct track length.

Attached is a screenshot of the issue. Here is a link to one of the songs that cause the issue for me (it's too big to upload here) : https://mega.nz/#!cskBgLTb!9Sh1lJaNyfzE_GuRnUtZsl-s_36pKmkMZod9v7rEs9Q

Screenshot_2016-09-10_15-16-17.png (118 KB) Screenshot_2016-09-10_15-16-17.png Not My Real Name, September 10, 2016 15:25

History

#1 Updated by John Lindgren about 5 years ago

  • Status changed from New to Rejected

Not a bug. Most MP3 files do not include accurate length information, so the value displayed is a guess. Enable the "Use accurate length calculation (slow)" option in the MPG123 plugin settings if you can live with the performance penalty.

#2 Updated by Not My Real Name about 5 years ago

John Lindgren wrote:

Not a bug. Most MP3 files do not include accurate length information, so the value displayed is a guess. Enable the "Use accurate length calculation (slow)" option in the MPG123 plugin settings if you can live with the performance penalty.

I see, thank you, that fixed it. If you don't want to enable the more accurate version by default, an option would be to check the time length before playing the song. That way you don't have to check all songs that could be added at once. Audacity remains fast while still being more accurate than now.
That would at least avoid strange sightings like the one I mentioned in my first post. Your call, though.

#3 Updated by John Lindgren about 5 years ago

Unfortunately there's no good solution that will please everyone. If you're playing a file that's stored locally on a solid-state drive, then it's fine to read in the entire file to compute an accurate length before starting playback. But if we make that the default, then we'll get a bug report from someone playing files over a slow network link, because now there is a delay before his song starts to play.

The only real way to solve the problem is on the encoder side. If MP3 encoders would just set the length field in the ID3 tag correctly, then the length could be displayed both quickly and accurately. But MP3 encoders in the wild are a real mess; most don't set the length field at all, and others have been known to set it to a completely wrong value such as zero (we have a sanity check in Audacious now to detect that).

#4 Updated by Not My Real Name about 5 years ago

I see, interesting that the length tag wouldn't always be set correctly, even if it's one of the most important tags. Well, thank you for answering, anyways !

#5 Updated by Philipp Philipp 6 months ago

I think it's important to distinguish between the displayed track length (of any track in the plyalist) and the length of the track currently being played. The latter isn't just displayed, but it also affects the scrubber: If the true track is longer, it's impossible to seek to certain positions. If the true track is shorter, seeking past the true end will suddenly abort the playback.

Unfortunately there's no good solution that will please everyone.

How do other players do it? mpv, Celluloid, Rhythmbox and VLC all display the correct length. Does that imply that they would be slow to open a file from a slow (network) drive? Or have they found some other solution? Maybe they have a better guessing algorithm?

There are compromise solutions that would work well for everyone, they just might be difficult to implement. For instance, the guessed time could be played initially, but while the track is already playing, Audacious could run the slower and more accurate guess in the background and update the display and scrubber as soon as the accurate length is available.

Also available in: Atom PDF