Project

General

Profile

Bug #681

audtool playback control

Added by Netslovdlyasnov Netslovdlyasnov about 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Major
Assignee:
-
Category:
-
Target version:
-
Start date:
November 21, 2016
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

audtool playback-pause works like playback-playpause, but it should only pause.
audtool playback-playing returns 0 in any case

History

#1 Updated by John Lindgren about 3 years ago

  • Status changed from New to Rejected

Working as intended, not a bug.

#2 Updated by Netslovdlyasnov Netslovdlyasnov about 3 years ago

How do I pause playback then?
If it is currently playing - it's ok, but if it's paused it starts playing.
I want to pause unconditionally.

#3 Updated by John Lindgren about 3 years ago

#!/bin/sh
if ! audtool playback-paused ; then audtool playback-pause ; fi

The forum is the best place for "how to" questions.

#4 Updated by Netslovdlyasnov Netslovdlyasnov about 3 years ago

Ok, that's one way of doing this, but

if audtool playback-playing; then audtool playback-pause; fi

doesn't work and it is a bug.
Also by logic there is a special command "playback-playpause" to toggle playback, and "playback-pause" must only pause, not starting playback again if paused.

Also available in: Atom PDF