Project

General

Profile

Bug #737

overdrive reproducing gain with setting 0,0 dB

Added by Stanislaw Schmidt 7 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
plugins/jack
Target version:
Start date:
August 03, 2017
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

I use Audacious as my primary player, under Ubuntu.
I use jack with floating point setting.
When playing MP3, FLAC, WAV, and playing CD, Calf JACK and Jkmeter display overdrive even though I have set playback gain to 0.0 dB. I do not want to use any limiter (option "prevent overdrive") in order not to restrict playback dynamics, so I set playback gain down to -7.5 dB.
It would be better if the reproduction gain were correct at 0.0 dB.
Thank you

Wiedergabeverstärkung .png (566 KB) Wiedergabeverstärkung .png Stanislaw Schmidt, August 03, 2017 14:08
Wiedergabeverstärkung .png (525 KB) Wiedergabeverstärkung .png Stanislaw Schmidt, August 03, 2017 15:47
Wiedergabeverstärkung .png (587 KB) Wiedergabeverstärkung .png Stanislaw Schmidt, August 04, 2017 08:29

History

#1 Updated by John Lindgren 7 months ago

  • Assignee deleted (Thomas Lange)

So you turned off "prevent clipping" and you get clipping? Sounds like a non-bug to me.

#2 Updated by Stanislaw Schmidt 7 months ago

Yes I turned off "prevent clipping", Look at my attachment file Wiedergabeverstärkung.png.
Function "prevent clipping" is a limitation of the signal, which causes compression with dynamic limitation.
Ich bin der Meinung, wenn eine Wiedergabeverstärkung auf 0,0 dB gesätzt ist, soll sie 0,0 dB nicht überschreiten.
I think that if a playback gain is set to 0.0 dB, it should not exceed 0.0 dB.
I also tried with the option "playback enhancement" switched off and turned off "prevent clipping", got the same result with overdriving the signal

#3 Updated by Stanislaw Schmidt 7 months ago

Yes I turned off "prevent clipping", Look at my attachment file Wiedergabeverstärkung.png.
Function "prevent clipping" is a limitation of the signal, which causes compression with dynamic limitation.
I think that if a playback gain is set to 0.0 dB, it should not exceed 0.0 dB.
I also tried with the option "playback enhancement" switched off and turned off "prevent clipping", got the same result with overdriving the signal

#4 Updated by John Lindgren 7 months ago

  • Status changed from New to Rejected

Prevent clipping does not compress the signal; it applies a constant volume factor every sample. You misunderstand what the options do and so you are not using them correctly. It's understandable since there is not much documentation, but still not a bug.

#5 Updated by Stanislaw Schmidt 7 months ago

The variant you prefer does not make what it should
I also tried with the option " Prevent clipping" , got the same result with overdriving the signal
I turned on "prevent clipping", Look at my attachment file Wiedergabeverstärkung.png.

#6 Updated by John Lindgren 7 months ago

There are many reasons you could be getting clipping. Please move your discussion to the forum and add more information (to start with: example input file, complete configuration settings, and FileWriter output) so that other users can help you identify the cause.

Also available in: Atom PDF