Project

General

Profile

Support #824

Fails to properly install from source on CentOS 7.5

Added by Yao Mitachi 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
libaudcore
Target version:
-
Start date:
August 29, 2018
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

I didn't notice any errors during the configure/install process, but when I went to try to install audacious-plugins: "Cannot find Audacious 3.10". Audacious itself fails to launch with this error:

audacious: error while loading shared libraries: libaudcore.so.5: cannot open shared object

I've attached the terminal output from my attempt to configure and install audacious and audacious-plugins.

audacious-install.txt (15.4 KB) audacious-install.txt Yao Mitachi, August 29, 2018 22:15
audacious-plugins-install.txt (3.12 KB) audacious-plugins-install.txt Yao Mitachi, August 29, 2018 22:15
Screenshot from 2018-08-30 18-11-17.png (202 KB) Screenshot from 2018-08-30 18-11-17.png Yao Mitachi, August 30, 2018 22:12

History

#1 Updated by John Lindgren 9 months ago

The first issue you will need to solve is this: "checking for AUDACIOUS... no". The log claims to have installed audacious.pc, but pkg-config on your system isn't able to find it. It's probably in /usr/local/lib/pkgconfig -- if so, try setting PKG_CONFIG_PATH=/usr/local/lib/pkgconfig, then reconfigure and rebuild audacious-plugins.

Note that you need to configure both audacious and audacious-plugins with --enable-qt if you want to use the Qt interface.

The second issue ("libaudcore.so.5: cannot open shared object file") is probably also path-related. The log claims to have installed libaudcore.so. Try to find that file, and determine if it is in the system's shared library path. It's probably in /usr/local/lib or some similar path -- if so, try setting LD_LIBRARY_PATH=/usr/local/lib before you run audacious.

#2 Updated by Yao Mitachi 9 months ago

That worked, thanks! I don't have any FFMPEG or AAC libraries, but I think I can do without those.

#3 Updated by Yao Mitachi 9 months ago

Uh, huh... I don't think that's supposed to look like that.

#4 Updated by John Lindgren 9 months ago

  • Status changed from New to Closed

Yao Mitachi wrote:

That worked, thanks!

Okay, good. Closing.

Also available in: Atom PDF