Project

General

Profile

Bug #901

Media controls no longer work in KDE Plasma

Added by Filip Fila about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
September 15, 2019
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Hi there, first of all thanks for this program!

I've been using it for quite some time but there have unfortunately been some changes in KDE Plasma,(since 5.16.4) resulting in its media applet no longer connecting to Audacious. This means, among other things, media keys no longer work.

As per KDE developer: "Audacious doesn't implement MPRIS correctly. It lacks the SupportedUriSchemes and SupportedMimeTypes properties on the MediaPlayer interface which are mandatory.

This update made media controller more strict about following the spec to guard plasma against fishy DBus traffic. We've had plasmashell crash in the past by players sending incorrect replies (e.g. string-string dict instead of string-variant dict, triggering asserts in libdbus). Sorry about that."

Would it be possible to implement the changes he mentioned?

History

#1 Updated by John Lindgren about 1 month ago

  • Status changed from New to Rejected

Please check for recently fixed issues before opening a new report. Duplicate of #900.

Also available in: Atom PDF