Project

General

Profile

Bug #903

Lyrics Plugin on Audacious 3.10.1 Windows URL needs to change.

Added by Anonymous about 1 month ago. Updated 29 days ago.

Status:
Rejected
Priority:
Critical
Assignee:
-
Category:
plugins/lyricwiki
Target version:
Start date:
September 20, 2019
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Hello, I would like to report that the Lyrics Plugin on Audacious 3.10.1 (jilindgren build 20181226) needs some fixing.
As of right now, the URL (http://lyrics.wikia.com/api.php) has changed to https://lyrics.fandom.com/api.php

The LyricWiki Plugin shows an error because of it.

Error
Unable to fetch http://lyrics.wikia.com/api.php?action=lyrics&artist=Dr.%20Alban&song=It%27s%20My%20Life&fmt=xml

On Windows 10 the lyricwiki.dll located in
C:\Program Files (x86)\Audacious\lib\audacious\General
Needs the URL changed.

I know it redirects to it but I'm not sure if the plugin knows how to do it. I suspect it doesn't and is why the error shows.
Please fix it so the Plugin works again. Thanks.

2019-09-20_15-03-35.jpg (25.1 KB) 2019-09-20_15-03-35.jpg Anonymous, September 20, 2019 21:03

History

#1 Updated by John Lindgren 29 days ago

  • Status changed from New to Rejected

Duplicate of #888.

Also available in: Atom PDF