Project

General

Profile

Bug #966

audtool segfaults in g_dbus_connection_close_sync() occasionally

Added by Igor Kushnir over 1 year ago. Updated about 2 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
audtool
Start date:
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Most of the crashes in the attachment happened to audtool called by my application, not manually. But today when I run `audtool help` from terminal, it displayed the help message and segfaulted. I don't know if versions other than 3.10.1 and 4.0.1 are affected, because my coredumpctl list goes back less than five months.

coredumpctl info audtool.txt (18.4 KB) coredumpctl info audtool.txt Igor Kushnir, April 13, 2020 12:37

History

#1 Updated by John Lindgren over 1 year ago

I cannot reproduce this. The backtrace is deep in some GLib code so it doesn't look like our bug at first glance.

(edit: typo)

#2 Updated by Igor Kushnir over 1 year ago

audtool is one of the most common programs in my coredumpctl list. audtool runs only for a very short time, though many times every day on my system. So this launch frequency could be a reason it crashes relatively often. Or perhaps it's something about how audtool is built.

#3 Updated by John Lindgren over 1 year ago

Well, the backtraces are all identical, and all within g_dbus_connection_close_sync(). I suspect there is a bug in that function -- maybe related to it being called in an atexit() handler.

To get to the root of this, someone will have to find a way to reliably reproduce it, and then spend some time debugging that call tree in GLib. I don't have the time to do this myself.

#4 Updated by John Lindgren over 1 year ago

  • Subject changed from audtool segfaults occasionally to audtool segfaults in g_dbus_connection_close_sync() occasionally

#5 Updated by John Lindgren about 2 months ago

Has anyone else reproduced this in >1 year?

#6 Updated by Igor Kushnir about 2 months ago

My current coredumpctl list starts on 2021-02-17 and contains no audtool entries. I think this issue can be closed. Must have been fixed somewhere, somehow.

#7 Updated by John Lindgren about 2 months ago

  • Status changed from New to Rejected

Okay thanks for the update!

Also available in: Atom PDF