Project

General

Profile

Support #984

configure & meson.build : Qt5 shouldn't be required for GTK3

Added by JP Guillemin 29 days ago. Updated 28 days ago.

Status:
Closed
Priority:
Major
Assignee:
-
Category:
-
Target version:
Start date:
May 03, 2020
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Hi,

Please remove useless Qt5 dependency foçr GT3 build.

Qt5 is an enormous bazar that "GTK only" desktop environments must not have to install.

diff -rNaud audacious-4.0.3-old/configure audacious-4.0.3/configure
--- audacious-4.0.3-old/configure    2020-05-03 09:57:40.387914172 +0200
+++ audacious-4.0.3/configure    2020-05-03 09:57:57.365913828 +0200
@@ -6700,7 +6700,7 @@
 if test "${enable_qt+set}" = set; then :
   enableval=$enable_qt; USE_QT=$enableval
 else
-  USE_QT=yes
+  USE_QT=no
 fi

History

#1 Updated by John Lindgren 29 days ago

I'm not sure I understand the issue here. Are you using meson or ./configure && make?

If you're using ./configure, did you pass --disable-qt?

#2 Updated by John Lindgren 29 days ago

  • Subject changed from BUG in configure & meson.build : Qt5 shouldn't be required for GTK3 to configure & meson.build : Qt5 shouldn't be required for GTK3
  • Tracker changed from Bug to Support

#3 Updated by John Lindgren 29 days ago

  • Category deleted (core)

#4 Updated by JP Guillemin 29 days ago

Yes, indeed, caused by the bug in both configure and meson : Qt is always required even if --disable-qt is passed to the configuration args.

Please take a look at my patch for configure : it's obvious :

 if test "${enable_qt+set}" = set; then :
   enableval=$enable_qt; USE_QT=$enableval
 else
- USE_QT=yes
+ USE_QT=no
 fi

It is really a bug !

#5 Updated by John Lindgren 28 days ago

  • Status changed from New to Closed

No, you are misunderstanding the logic there. I build on a system without Qt before every release. It is not required.

Also available in: Atom PDF