Project

General

Profile

Support #997

Revert playlist to original sorted order

Added by el la 12 months ago. Updated 12 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Start date:
June 16, 2020
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Add option to revert a playlist to the original sorted order (the same order when drag-and-drop songs to a playlist).

History

#1 Updated by John Lindgren 12 months ago

  • Tracker changed from Bug to Support

Drag-and-drop adds files in order of path. So Playlist -> Sort -> By File Path will restore that ordering.

#2 Updated by el la 12 months ago

1. What if you don't add songs all at once (pick and choose different songs by drag and drop)?

2. What if you open an existing playlist, and sort according to name. How do you restore the original sorting? You can't unless you reopen the same playlist again.

I think each playlist needs to have a song order property that shows the order of the songs in the playlist (it should be a number).

#3 Updated by John Lindgren 12 months ago

  • Status changed from New to Rejected

That would be a form of undo operation, so we'll consider this a duplicate of #544. Feel free to take it and work on it.

Also available in: Atom PDF