Bug #117

cdaudio-ng: Translations are not applied

Added by Thomas Lange about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:May 30, 2012
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/cdaudio
Target version:3.3
Affects version:3.3

Description

Title says all.
Probably caused by the transition to "PluginPreferences",
although other plugins don't have this issue.

By the way, the category "cdaudio-ng" is missing in this bugtracker.

Associated revisions

Revision 324a751b
Added by John Lindgren about 5 years ago

cdaudio-ng: Fix wrong PACKAGE definition being used, and use about_text. Closes: #117.

History

#1 Updated by John Lindgren about 5 years ago

Have you made sure that audacious-plugins.pot is up to date and that no strings are untranslated?

#2 Updated by John Lindgren about 5 years ago

  • Assignee deleted (John Lindgren)

#3 Updated by MichaƂ Lipski about 5 years ago

  • Category set to plugins/cdaudio

#4 Updated by Thomas Lange about 5 years ago

Take a look at:
https://github.com/audacious-media-player/audacious-plugins/blob/8c4fbaabec47e8036f4c94c25b77e220cd4e6f97/po/de.po#L939

All lines (e.g. 108) matches with the source file.
I've executed "make update-pot" just now but it's still "POT-Creation-Date: 2011-12-29 19:29-0500\n".

The po file itself is up to date though (update-pot-files.sh and make update-po).

#5 Updated by John Lindgren about 5 years ago

"make update-pot" turned out to be broken by a missing line in extra.mk. Can you see if the problem is resolved with a clean build of current git?

#6 Updated by John Lindgren about 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Found the real problem. PACKAGE was being redefined by libcdio headers; hence the wrong gettext domain was being searched.
https://github.com/audacious-media-player/audacious-plugins/commit/324a751bf7ae5f3a03ea8762fd881648b6b79bdd

Also available in: Atom PDF