Bug #178

"Close to tray icon" doesn't work when using Winamp interface

Added by J1 Simon about 2 years ago. Updated about 2 years ago.

Status:Closed Start date:September 23, 2012
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/skins
Target version:3.3.3
Affects version:3.3.1

Description

Ubuntu 12.04 64 bits
Gnome-shell 3.4.1
audacious 3.3.1

I have activated the "_Status icon_" plugin and its option "_close to tray icon_", but when I close the audacious window, it closes de app.

Associated revisions

Revision 64c6bd15
Added by John Lindgren about 2 years ago

skins: Call "window close" hook to check whether we need to quit or not. Closes: #178.

Revision d2df9da0
Added by John Lindgren almost 2 years ago

skins: Call "window close" hook to check whether we need to quit or not. Closes: #178.

History

#1 Updated by John Lindgren about 2 years ago

It works perfectly here (XFCE 4.10).

#2 Updated by Thomas Lange about 2 years ago

It works also for me with Gnome 3.6b2.

#3 Updated by John Lindgren about 2 years ago

I tested Ubuntu 12.04 with Unity just now, and though Unity does not display the icon, the "close to tray icon" behavior still works; the program continues to run and music continues to play.

#4 Updated by J1 Simon about 2 years ago

I have compiled the version 3.3.2 and same problem.

#5 Updated by Thomas Lange about 2 years ago

I can't reproduce this even with Ubuntu 12.04.1 and gnome-shell.
Have you tried using a clean user profile?

#6 Updated by Thomas Lange about 2 years ago

Please tell us next time you are using the Winamp skin.
Now I am able to reproduce the issue.

#7 Updated by J1 Simon about 2 years ago

Thomas Lange wrote:

Please tell us next time you are using the Winamp skin.
Now I am able to reproduce the issue.

Yes, it's true. I use the Winamp skin.

#8 Updated by John Lindgren about 2 years ago

  • Subject changed from Option "close to tray icon" of Status icon plugin doesn't work to "Close to tray icon" doesn't work when using Winamp interface
  • Category changed from plugins/statusicon to plugins/skins

#9 Updated by John Lindgren about 2 years ago

  • Status changed from New to Closed
  • Target version set to 3.3.3
  • % Done changed from 0 to 100

Also available in: Atom PDF