Bug #218

"Close Playlist" dialog ignores GTK dialog button order

Added by Stephan Sokolow almost 2 years ago. Updated almost 2 years ago.

Status:Closed Start date:November 26, 2012
Priority:Minor Due date:
Assignee:- % Done:

0%

Category:libaudgui
Target version:-
Affects version:3.3.2

Description

When gtk-alternative-button-order=0, GTK+ applications are supposed to put the OK/Yes/Confirm button to the right of the Cancel/No button. (GNOME/MacOS order)

However, contrary to every other application on my desktop (including Qt applications via GtkStyle), Audacious's "Close Playlist" dialog uses KDE/Windows button order and puts "Yes" to the left of "No".

snapshot1.png - Affected dialog (19.8 kB) Stephan Sokolow, November 26, 2012 06:11

snapshot2.png - Other GTK+ dialog on the same desktop for comparison (10.8 kB) Stephan Sokolow, November 26, 2012 06:11

snapshot3.png - Qt dialog on the same desktop for comparison (18.8 kB) Stephan Sokolow, November 26, 2012 06:11

confirm.patch Magnifier (4.4 kB) Thomas Lange, November 26, 2012 16:51

Associated revisions

Revision f2f1b8fc
Added by Thomas Lange almost 2 years ago

libaudgui: Respect 'gtk-alternative-button-order' setting. Fixes #218

Revision d4cfccf2
Added by Thomas Lange almost 2 years ago

libaudgui: Respect 'gtk-alternative-button-order' setting. Fixes #218

History

#1 Updated by Thomas Lange almost 2 years ago

  • File confirm.patchMagnifier added
  • Category changed from plugins/gtkui to libaudgui

Thanks for your bug report Stephan.

The bug is caused by using a GtkWindow with custom content instead of a GtkMessageDialog.
Attached is a patch which fixes this. John, please review.

Should I use a gpointer parameter in "confirm_delete_cb()"?

#2 Updated by John Lindgren almost 2 years ago

Looks good. Personally I prefer (void *) instead of gpointer, int instead of gint, etc.

#4 Updated by Thomas Lange almost 2 years ago

  • Status changed from New to Resolved

#5 Updated by Thomas Lange almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF