Bug #317

Tray icon missing after restarting xfce4-panel

Added by Marcin Kocur 9 months ago. Updated 9 months ago.

Status:Closed Start date:July 12, 2013
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/statusicon
Target version:3.4.1
Affects version:3.4

Description

Audacious is playing music, status icon is enabled, now I'm restarting xfce4 pannel:

dbus-send --session --dest=org.xfce.Panel /org/xfce/Panel org.xfce.Panel.Terminate boolean:'true'

Audacious is still playing music, but there is no tray icon.

This bug exists in version 3.4 but there is no such one in bugtracker.

taskbar.png (8.6 kB) Marcin Kocur, July 17, 2013 12:00

notification_area.png (34.2 kB) Thomas Lange, July 17, 2013 21:38

Associated revisions

Revision 928dea86
Added by John Lindgren 9 months ago

hotkey: Fix wrong return value that was filtering out events on the root window. Closes: #317.

Revision 74250e8e
Added by John Lindgren 8 months ago

hotkey: Fix wrong return value that was filtering out events on the root window. Closes: #317.

History

#1 Updated by John Lindgren 9 months ago

Does the same happen with other programs that use GtkStatusIcon?

#2 Updated by Marcin Kocur 9 months ago

John Lindgren wrote:

Does the same happen with other programs that use GtkStatusIcon?

Come on, I don't know what certain app uses to display tray icon :P Please look at my attachment. I have there thunderbird, xfce's file copying status icon, psi, liferea (rss reader for xfce) and I know also qbittorrent and konversation don't have such problems. Audacious is the only app which icon disappears.

#3 Updated by Thomas Lange 9 months ago

Are you talking about the "Notification Area" or the "Window Buttons" item in the Xfce panel?
If is is the latter, check its settings. Maybe "Hidden" is enabled for Audacious.

#4 Updated by Thomas Lange 9 months ago

latter -> former...

#5 Updated by Marcin Kocur 9 months ago

Thomas Lange wrote:

Are you talking about the "Notification Area" or the "Window Buttons" item in the Xfce panel?
If is is the latter, check its settings. Maybe "Hidden" is enabled for Audacious.

Wow, I didn't even know there is such feature in xfce! ;)

But no, audacious is not ticked to be hidden.

#6 Updated by Thomas Lange 9 months ago

You haven't answered my question, so
1. Do you mean the icon in the Notification area (with enabled StatusIcon plugin) or simply the tabbar entry?
2. Have you tried to reproduce this with a clean user profile?

#7 Updated by Marcin Kocur 9 months ago

Finally! I was able to reproduce this bug with a clean profile! :)

Thomas Lange wrote:

You haven't answered my question, so
1. Do you mean the icon in the Notification area (with enabled StatusIcon plugin) or simply the tabbar entry?

I mean tray/notification icon enabled by statusicon.so

2. Have you tried to reproduce this with a clean user profile?

Yes, here's the way you should be able to do it:

Enable in general plugins configuration both statusicon and global hotkeys (hotkey.so). Restart audacious. Now you can restart xfce panel with provided dbus command (or killall xfce4-panel && xfce4-panel but dbus is more elegant). The status icon is missing.

#8 Updated by Thomas Lange 9 months ago

xfce4-panel -r is even more elegant. ;)
Anyway, I am able to reproduce this with enabled hotkey plugin.

#9 Updated by Marcin Kocur 9 months ago

Glad to hear that :) Fixing this issue should also improve user's experience in other DE's when panel crashes or it's configuration is changed.

I didn't know -r argument. Well, I was wondering if there is any proper way of killing a generic graphical application like audacious from command line. The only thing I found was dbus-send --session --dest=org.atheme.audacious /org/atheme/audacious org.atheme.audacious.Quit but it's not very convenient.

#10 Updated by John Lindgren 9 months ago

Marcin Kocur wrote:

Well, I was wondering if there is any proper way of killing a generic graphical application like audacious from command line.

pkill audacious, or audtool shutdown.

#11 Updated by John Lindgren 9 months ago

  • Status changed from New to Closed
  • Target version set to 3.4.1
  • % Done changed from 0 to 100
  • Affects version 3.4 added

Enable in general plugins configuration both statusicon and global hotkeys (hotkey.so).

Thanks for that information. You should have stated from the start that you had enabled the hotkeys plugin.

Fixed:
https://github.com/audacious-media-player/audacious-plugins/commit/928dea8660db554f678fa3f164221eda67f221d9

#12 Updated by Marcin Kocur 9 months ago

John Lindgren wrote:

pkill audacious, or audtool shutdown.

The first method is wrong because it doesn't save application's configuration, and the second works only with audacious. But I guess it's not a guestion to be asked here.

Enable in general plugins configuration both statusicon and global hotkeys (hotkey.so).

Thanks for that information. You should have stated from the start that you had enabled the hotkeys plugin.

I would if I knew that hotkeys could be related to status icon. Seriously - would you come up on that? ;p

Fixed:
https://github.com/audacious-media-player/audacious-plugins/commit/928dea8660db554f678fa3f164221eda67f221d9

Thanks! ;)

Also available in: Atom PDF