Bug #364

Opus files are missed when opening folder

Added by jEsuSdA 8) 12 months ago. Updated 12 months ago.

Status:Closed Start date:November 01, 2013
Priority:Major Due date:
Assignee:- % Done:

100%

Category:plugins/ffaudio
Target version:3.4.3
Affects version:3.4.2

Description

Usually you can add several files recursively to the playlist clicling on open files and selecting a folder. Then Audacious loads the audio files containing in the selected folder and all the subfolders.

But if the folder and subfolder has opus files, these files are not loaded.

If you change the name of files, like song.opus.ogg, then the files are loaded, but if you let the original name, like song.opus, Audacious does not detect them.

Maybe there are some configuration file or some code when the file patterns are indicated (*.mp3, *.ogg, etc.) so you could simply add *.opus or maybe made some extra field on configuration gui to allow add new patterns.

Thanks!
;)

messiah_by_handel.opus - messiah_by_handel.opus (1.8 MB) jEsuSdA 8), November 04, 2013 21:22

Associated revisions

Revision 3e61a6c6
Added by John Lindgren 12 months ago

ffaudio: Add "opus" extension. Closes: #364.

Revision 92a8206a
Added by John Lindgren 12 months ago

ffaudio: Add "opus" extension. Closes: #364.

History

#1 Updated by John Lindgren 12 months ago

  • Category deleted (core)
  • Priority changed from Critical to Major

What version of Audacious are you running? This looks like a duplicate of #362.

#2 Updated by Michael Schwendt 12 months ago

I wonder whether the ffaudio plugin should list the ".opus" file extension as one it supports?

#3 Updated by John Lindgren 12 months ago

Michael Schwendt wrote:

I wonder whether the ffaudio plugin should list the ".opus" file extension as one it supports?

Maybe, but Audacious should play the files regardless of the file extension.

#4 Updated by jEsuSdA 8) 12 months ago

John Lindgren wrote:

What version of Audacious are you running? This looks like a duplicate of #362.

Audacious 3.4.1 (over Debian)

#5 Updated by jEsuSdA 8) 12 months ago

John Lindgren wrote:

Michael Schwendt wrote:

I wonder whether the ffaudio plugin should list the ".opus" file extension as one it supports?

Maybe, but Audacious should play the files regardless of the file extension.

That is!

If you let the files named as FILE.OPUS, Audacious does not load them. If you rename the same files to FILE.OPUS.OGG or FILE.OPUS.MP4, Audacious load them and play them as Opus files.

There must be a filetype filter on somewhere you can modify to add the .opus extension. ;)

Thanks!

#6 Updated by jEsuSdA 8) 12 months ago

I've just download the 3.4.2 version and compiled it and the bug persists.

The .opus files are not loaded. :(

Salu2 de jEsuSdA 8)

#7 Updated by John Lindgren 12 months ago

jEsuSdA 8) wrote:

There must be a filetype filter on somewhere you can modify to add the .opus extension. ;)

Please refrain from suggesting solutions until we have identified the problem.

#8 Updated by John Lindgren 12 months ago

Please attach one of the files that does not play.

#9 Updated by jEsuSdA 8) 12 months ago

John Lindgren wrote:

jEsuSdA 8) wrote:

There must be a filetype filter on somewhere you can modify to add the .opus extension. ;)

Please refrain from suggesting solutions until we have identified the problem.

Sorry, it was not a solution, it was only a supposition. Maybe my english is not too good and my message appears to be too much imperative. Sorry. Was my fault. I'm spanish and my english is not too good. ;)

#10 Updated by jEsuSdA 8) 12 months ago

John Lindgren wrote:

Please attach one of the files that does not play.

Here some of the files Audacious does not load if you select the folder instead the file itself.

Thank you for your efforts. ;)
jEsuSdA 8)

#11 Updated by John Lindgren 12 months ago

The file plays fine here in 3.4.2. Please attach the output of "audacious -V messiah_by_handel.opus".

#12 Updated by Thomas Lange 12 months ago

He says it does not play if you select a folder which contains the opus file.

The output is:

main.c:541 [main]: Startup complete.
probe.c:164 [file_find_decoder]: Probing file:///home/thomas/Desktop/test/messiah_by_handel.opus.
probe.c:120 [probe_by_scheme]: Probing by scheme.
probe.c:134 [probe_by_extension]: Probing by extension.
probe.c:194 [file_find_decoder]: Probe failed.

#13 Updated by John Lindgren 12 months ago

  • Subject changed from Audacious can not opens opus files directly to Opus files are missed when opening folder
  • Category set to plugins/ffaudio

Thomas Lange wrote:

He says it does not play if you select a folder which contains the opus file.

Oh. I missed that distinction. In that case the "opus" extension does need to be added to ffaudio.

#14 Updated by John Lindgren 12 months ago

  • Target version set to 3.4.3
  • % Done changed from 0 to 100
  • Affects version 3.4.2 added

#16 Updated by John Lindgren 12 months ago

  • Status changed from New to Closed

Also available in: Atom PDF