Bug #405

Invisible repeat button with Ivory and Osmosis skin

Added by Thomas Lange over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:February 17, 2014
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:plugins/skins
Target version:3.5
Affects version:3.4.3

Description

The repeat button of the Ivory skin is invisible.
Strangely Osmosis (Ivory inverted) is not affected.

Screenshot attached.

Ivory.png - screenshot (8.3 kB) Thomas Lange, February 17, 2014 23:10

Associated revisions

Revision 3b668665
Added by John Lindgren over 3 years ago

skins: Fix Ivory and Osmosis so repeat button does not extend outside window. Closes: #405.

History

#1 Updated by Thomas Lange over 3 years ago

  • Subject changed from Invisible repeat button with Ivory skin to Invisible repeat button with Ivory and Osmosis skin

This is getting even more confusing.

After a restart the button is invisible for one of the two skins.
If the other skin is selected, the button gets visible.
And the restart changes all again.

#2 Updated by John Lindgren over 3 years ago

This is a regression from the fix for #299.

The fix was not taking effect consistently; now it is:
https://github.com/audacious-media-player/audacious-plugins/commit/1cb8af47cbcb81308e3418feb702af7cd7b35221

So now the Ivory and Osmosis skins are consistently broken. :/

#3 Updated by John Lindgren over 3 years ago

  • Status changed from New to Closed
  • Target version set to 3.5
  • % Done changed from 0 to 100

Fixed by moving repeat and shuffle buttons to the left 5 pixels. Since actual Winamp 2 skins don't have a skin.hints file, I don't think we need to support displaying widgets partially outside the window boundary (and they would be a headache to support because of #299).

https://github.com/audacious-media-player/audacious-plugins/commit/3b6686655106e3b0628843b834efdda705ffc524

Also available in: Atom PDF