Bug #617

audacious -j does not open jump-to-file dialog

Added by Thomas Lange over 1 year ago. Updated about 1 year ago.

Status:Closed Start date:January 14, 2016
Priority:Minor Due date:
Assignee:- % Done:

100%

Category:core
Target version:3.7.2
Affects version:3.6, 3.7, 3.8

Description

The command "audacious -j" and "audacious --show-jump-box" are not opening the jump-to-file dialog anymore.

Affected versions are at least 3.6+ with both interfaces.

Associated revisions

Revision fabc5b80
Added by John Lindgren about 1 year ago

Fix -j and -m options not working at first startup. Closes: #617.

Revision cab5eb82
Added by John Lindgren about 1 year ago

Fix -j and -m options not working at first startup. Closes: #617.

History

#1 Updated by John Lindgren over 1 year ago

Works fine here.

#2 Updated by Thomas Lange over 1 year ago

That's strange. The reason is that current_interface is NULL in aud_ui_show_jump_to_song(), libaudcore/interface.cc#216.

#3 Updated by John Lindgren over 1 year ago

There might have to be a running instance already for it to work. I will try it later on the first instance and see if I can reproduce. Possibly aud_ui_show_jump_to_song() needs to be called later in the startup process.

#4 Updated by John Lindgren about 1 year ago

  • Category set to core
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF