Project

General

Profile

Audacious russian letters in filename

Added by Evg Evg over 6 years ago

Hello!

OS Raspbian, Audacious player ver.3.5

When you select File-> Open a song list with correct Russian and English filenames. English filenames plays. When you select the Russian filenames
an error "file: //home/pi/Music/%EF%FO%EE%E2%E5%F0%EA%E0.mp3 не может быть открыт"

And if you run from the command line
audacious проверка.mp3
then the file is playing normally.

Prompt, pliz, what could be the reason.


OS Raspbian, Audacious player ver.3.5

При выборе песен показывает список с читаемыми русскими и английскими именами файлов. Англоязычные имена проигрывает. При выборе русскоязычного
имени выдает ошибку " file://home/pi/Music/%EF%FO%EE%E2%E5%F0%EA%E0.mp3 не может быть открыт "

Причем если запустить из командной строки
audacious проверка.mp3
то файл проигрывается нормально.

Подскажите, плиз, в чем может быть причина.


Replies (9)

RE: Audacious russian letters in filename - Added by John Lindgren over 6 years ago

Under File -> Settings -> Playlist -> Compatibility, try setting "Auto character encoding detector" to Russian. If that doesn't help, set it back to None and try adding the character encoding of the playlist you are trying to open under "Fallback character encodings" instead.

RE: Audacious russian letters in filename - Added by Evg Evg over 6 years ago

It doesn't help.
In list ( playlist or File->Open ) i see correct russian filenames. But when i try to play it, error message.

RE: Audacious russian letters in filename - Added by Thomas Lange over 6 years ago

Please start Audacious with "LC_ALL=C audacious" to get English error messages.

RE: Audacious russian letters in filename - Added by Evg Evg over 6 years ago

pi@raspberrypi ~ $ LC_ALL=C audacious

  • (audacious:3172): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
    Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/проверка.mp3

(audacious:3172): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()
Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/проверка.mp3
Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/проверка.mp3

  • (audacious:3172): CRITICAL **: local_fopen: assertion 'path' failed

--------------------------------------------------------
! Run OTHER FILE !
---------------------------------------------------------

pi@raspberrypi ~ $ LC_ALL=C audacious

  • (audacious:2977): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
    Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/Лепс_Берега.mp3
  • (audacious:2977): CRITICAL **: local_fopen: assertion 'path' failed
    Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/Лепс_Берега.mp3
    Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/Лепс_Берега.mp3
  • (audacious:2977): CRITICAL **: local_fopen: assertion 'path' failed
    Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/Лепс_Берега.mp3
  • (audacious:2977): CRITICAL **: local_fopen: assertion 'path' failed
    Cannot convert to locale (ANSI_X3.4-1968): /home/pi/Music/mp3_ringtone/Лепс_Берега.mp3
    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

RE: Audacious russian letters in filename - Added by John Lindgren over 6 years ago

The problem is almost certainly the use of a legacy (non-UTF-8) character encoding without configuring Audacious correctly for it. Until we know what encoding it is, we cannot help you. You said "It doesn't help" but you didn't say what encodings you tried.

RE: Audacious russian letters in filename - Added by John Lindgren over 6 years ago

Also you should try a more recent version; there were some character encoding fixes in 3.6 and 3.7. It may "just work" once you upgrade.

RE: Audacious russian letters in filename - Added by Evg Evg over 6 years ago

Problem fixed!

Solution:
1. sudo dpkg-reconfigure locales
2. select all with starting "ru_RU"
3. set "ru_RU.UTF-8" as default
4. reboot
5. in Audacious: File -> Settings -> Playlist -> Compatibility, set "Auto character encoding detector" to Russian
6. Enjoy !

Thank you all !

RE: Audacious russian letters in filename - Added by Thomas Lange over 6 years ago

Glad you could fix it. :) What was your default locale before?

RE: Audacious russian letters in filename - Added by Evg Evg over 6 years ago

I don't looked for default. Run dpkg-reconfigure for experiment... :)

    (1-9/9)