Project

General

Profile

Problems Loading LADSPA Plugins

Added by John Slane 5 months ago

I am setting up Audacious 3.9 in a fresh install of Linux Mint 19.1. Audacious is running fine, but I cannot get it to recognize the LADSPA plugins. I used those plugins regularly in Audacious in my previous OS (Mint 17). Here is how I am approaching it:
- Installed tap-plugins via Synaptic Package Manager
- Checked to make sure that /usr/lib/ladspa was created and that it contained all the plugins (.so files).
- In Audacious, went to Settings > Plugins > Effect > LADSPA Host and checked it and selected it
- Clicked on Settings
- Typed the path /usr/lib/ladspa/
- Clicked on Enable
Nothing happens. No plugins are shown in the window. Closing and reopening Audacious does not help.

Could this be a permissions issue? /usr/lib/ladspa is owned by root, but that was the case in my old install on the previous OS. So I'm not sure why this would be a problem now.

Worked on this for quite a while with no success. Any guidance would certainly be appreciated!


Replies (2)

RE: Problems Loading LADSPA Plugins - Added by John Lindgren 5 months ago

John Slane wrote:

- Typed the path /usr/lib/ladspa/
- Clicked on Enable

This might be a stupid question, but did you press Enter after typing "/usr/lib/ladspa"? There's a small note in the config dialog that says to do that, but it's easy to miss.

I don't have a Linux Mint machine, but audacious 3.9-2 and tap-plugins 1.0.0-1 seem to work together all right on my Ubuntu 18.10 machine:

RE: Problems Loading LADSPA Plugins - Added by John Slane 5 months ago

OMG!!!!!!!!!!!

I don't know how many times I typed that path in there --- and I must have NEVER hit ENTER!!

I even moved the plugins to a different path and tried that. Obviously, that was futile.

Can't follow simple directions.

I read the part about separating multiple paths and stupidly assumed I could ignore the rest.

I am very indebted to you for replying to my question.

    (1-2/2)