Project

General

Profile

Feature Support: new VGM gme version 0.7.0 (or 0.6.0 at least)

Added by Ere Cab 5 months ago

Hello.
I would like to ask for an update to the console.so VGM input driver. The old gme 0.5.2 has been revised since.
Some VGM ripped with emulation tools (MESS) won't play with current .so version (based on gme 0.5.2), particularly some GB/GBA rips (sample attached).
vgmplay plays them fine, but I (and many of us) would like this convenience for audacious instead of a terminal program (linux).
Or alternatively, port libvgm [https://github.com/ValleyBell/libvgm] to audacious as an updated (replacement for?) gme.
Here is the updated vgm spec [https://vgmrips.net/misc/vgmspec171.txt]
Thank you.

01 Title.vgm (12.3 KB) 01 Title.vgm sample .vgm file

Replies (1)

RE: Feature Support: new VGM gme version 0.7.0 (or 0.6.0 at least) - Added by Ariadne Conill 13 days ago

The version of GME we include in Audacious is highly modified. I can look into porting the GME 0.7 features.

    (1-1/1)