Scrobbling to

Added by Franko Burolo over 10 years ago

Seems like the new scrobbler doesn't offer any option to scrobble to, which is a free software project, just like Audacious is... Would be nice to support it.

Earlier versions of the Scrobbler offered the possibility to write-in the scrobbling server, which allowed us to scrobble to, or any other service, for that matter. Not possible anymore. So I guess this could be considered a regression of sort... But I wasn't sure whether to report it as a bug, so I am putting it here for now.

Would it be possible to re-enable the option of scrobbling to in the new scrobbler? Or, at least, to install Scrobbler v.1 in Audacious 3.4?

Thank you very much!

Replies (7)

RE: Scrobbling to - Added by John Lindgren over 10 years ago changed to a completely new API, which is why the new Scrobbler was written. Do you know if has done the same?

For now, you can copy the old scrobbler plugin from Audacious 3.3 and it should work with Audacious 3.4 as well.

RE: Scrobbling to - Added by Franko Burolo over 10 years ago

No, I don't think has done significant changes. Scrobbles from my Crunchbang (Debian stable) machine, which has an older version of Audacious, still scrobble just fine there.

I tried copying from an older deb package (Ubuntu) and replacing the default /usr/lib/x86_64-linux-gnu/audacious/General/ with it on my Ubuntu 13.10 system, but I couldn't access the plugin that way, at all... So restored the default one.
I am not sure about what version I tried for that... I will retry with 3.3 and see what happens. Or maybe I did something wrong?

On another note, whatever you scrobble to can be forwarded to, which still works fine, too. This could be a potential workaround for the cert issue...

Anyhow, thank you very much for the answer! I will check in again when I re-try with the scrobbler from v.3.3. :-)

RE: Scrobbling to - Added by Franko Burolo over 10 years ago

Wow! It works, after all! :-) Not sure what have I done wrong the last time...

Anyway, it would still be nicer and cleaner to have a option in the new scrobbler.
But still, thank you for the suggestion! :-)

RE: Scrobbling to - Added by Luís Picciochi over 10 years ago

Hi Franko,

I just checked that claims to support the 2.0 API1. This means that this may be feasible. It'll have to be tested to make sure everything works.
In any event, please create a feature request on the issue tracker so this doesn't get forgotten.



RE: Scrobbling to - Added by Franko Burolo almost 10 years ago

Just did it. Sorry I didn't do it before... I didn't visit the forums for quite some time, so I didn't see your post until tonight.

Thank you very much for your concern! :-)

RE: Scrobbling to - Added by Franko Burolo over 9 years ago

The above workaround doesn't work anymore with Audacious 3.5 on Ubuntu 13.10... There seems to already exist a patch for the v.2 Audacious scrobbler, but I don't know how to compile that. But maybe it could be used for fixing bug #429?