Project

General

Profile

Bug #1050

[i18n] Missing Qt translations

Added by Arek Kentski 7 months ago. Updated 6 months ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
plugins/qtui
Target version:
Start date:
January 09, 2021
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Non-English locale, some Qt-based elements (like certain context menus and dialog windows) are in English. The GTK mode is fine (all translated). Tested with audacious-4.1-beta1-win32.

1.png (4.07 KB) 1.png Arek Kentski, January 09, 2021 21:21
2.png (27.2 KB) 2.png Arek Kentski, January 09, 2021 21:21

History

#1 Updated by Thomas Lange 7 months ago

Thanks, but this has already been reported as #569.
At least we know now this occurs on Windows as well.

#2 Updated by John Lindgren 7 months ago

Is it just files missing from the installer/zip file?

I honestly don't know how to test translations under Windows. In Linux you can just change the LANG variable. I don't know what the Windows equivalent is.

#3 Updated by Arek Kentski 7 months ago

John Lindgren wrote:

Is it just files missing from the installer/zip file?

I honestly don't know how to test translations under Windows. In Linux you can just change the LANG variable. I don't know what the Windows equivalent is.

I don't really know. It seems that the "translations" folder filled with *.qm files is required and that folder must be "enabled" in app's source code.

#4 Updated by Thomas Lange 7 months ago

Arch Linux for example provides the package qt5-translations:
https://archlinux.org/packages/extra/any/qt5-translations/files/

The Windows Qt build should probably ship the required qm files as well.
But we also have to import them via code, see my original patch in #569.

In Linux you can just change the LANG variable. I don't know what the Windows equivalent is.

I think we should first make sure it works on Linux, afterwards we can tackle the Windows Installer.

#5 Updated by John Lindgren 6 months ago

  • Status changed from New to Rejected

Closing as duplicate of #569 (which is now fixed).

Also available in: Atom PDF