Project

General

Profile

Bug #1132

Qt Interface loses Album Art setting if closing main window (Wayland specific)

Added by Michael Schwendt about 1 month ago. Updated 22 days ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Start date:
November 01, 2021
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Steps to reproduce:

1. enable Album Art plugin
2. close Audacious window via 'X' button instead of choosing "File > Quit"
3. restart Audacious
4. Album Art plugin is disabled again

Only if quitting the program via "File > Quit", the album art setting is preserved.

History

#1 Updated by John Lindgren 23 days ago

I can't reproduce this. Could it possibly be related to a particular Qt version?

(Shutting down an application in an orderly fashion seems to be a weak point in Qt, and hard to "get right" for an application as complex as Audacious. We've had issues in the past where our code works fine with one Qt version and/or OS, only to crash on another.)

#2 Updated by Michael Schwendt 23 days ago

Indeed it's not reproducible with GNOME Shell on Xorg or GNOME Classic, but only with GNOME Shell on Wayland.

#3 Updated by John Lindgren 23 days ago

  • Subject changed from Qt Interface loses Album Art setting if closing main window to Qt Interface loses Album Art setting if closing main window (Wayland specific)

#4 Updated by John Lindgren 22 days ago

I'm going to close this (like #1080 and #1094) because we don't support Wayland yet.

Patches to fix Wayland-specific issues are of course welcome, but I suspect most of the issues need to be fixed in Qt and/or the compositor(s).

#5 Updated by John Lindgren 22 days ago

  • Status changed from New to Rejected

Also available in: Atom PDF