Project

General

Profile

Bug #125

Opening the preferences window causes a short sound delay

Added by Thomas Lange over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Trivial
Assignee:
-
Category:
core
Target version:
Start date:
June 11, 2012
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

If you open the preferences window, there is a short delay in playback.
This is only occurring with 3.3.

audacious -V prints:
effect.c:68 [effect_start]: Starting effects.

Is the delay caused by the effects?

History

#1 Updated by John Lindgren over 8 years ago

  • Category set to core
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Not exactly. What was happening is this: the dropdown menu for the output bit depth was (wrongly) emitting a "changed" signal when it was created. Until recently, the signal was ignored, but now it resets the output plugin so that the new setting takes effect immediately. That reset caused the delay you heard.

Fixed:
https://github.com/audacious-media-player/audacious/commit/42f76d475899476076ccd5216de5eba23fcecce9

Also available in: Atom PDF