Project

General

Profile

Bug #139

Files with a sample rate less than 33kHz don't play

Added by Alister Hood about 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Start date:
June 30, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Files with a sample rate less than 33kHz give me the error message "snd_pcm_hw_params failed: Invalid argument".
These files play successfully in other software.

e.g. the attached 22k.mp3 and 32k.wav don't play, but 33k.wav and 44k.mp3 do play.

22k.mp3 (287 KB) 22k.mp3 Alister Hood, June 30, 2012 15:12
32k.wav (1.12 MB) 32k.wav Alister Hood, June 30, 2012 15:12
33k.wav (1.15 MB) 33k.wav Alister Hood, June 30, 2012 15:12
44k.mp3 (287 KB) 44k.mp3 Alister Hood, June 30, 2012 15:12

History

#1 Updated by Alister Hood about 8 years ago

FWIW I'm running Arch Linux.

#2 Updated by John Lindgren about 8 years ago

  • Status changed from New to Rejected

Not a bug. This error message means your sound card doesn't support such rates. Other software is probably resampling the files. You can make Audacious do the same by using the sample rate converter plugin.

#3 Updated by Alister Hood about 8 years ago

Ah, thanks.
It's not exactly obvious for the average user...

#4 Updated by John Lindgren about 8 years ago

We report the error exactly as it comes from ALSA (more specifically, snd_strerror()). If you are confused by ALSA error messages, you can do what many Linux users do and ask on some forum (ours even), "What does error message XXX mean, and how do I fix it?"

#5 Updated by John Lindgren about 8 years ago

Also, I don't know what you have done to your ALSA setup, but the average user (even on Arch Linux) will not run into such errors because for most sound cards, DMix is enabled by default and handles the necessary resampling.

#6 Updated by Alister Hood about 8 years ago

John Lindgren wrote:
We report the error exactly as it comes from ALSA (more specifically, snd_strerror()). If you are confused by ALSA error messages, you can do what many Linux users do and ask on some forum (ours even), "What does error message XXX mean, and how do I fix it?"

Yes, I should really have done that, sorry.
At least now if someone googles this error they can find it here.

#7 Updated by Alister Hood almost 8 years ago

I don't know what you have done to your ALSA setup

It was caused by "defaults.pcm.dmix.rate 44100" in a config file.

Also available in: Atom PDF