Project

General

Profile

Feature #184

Hide "Services" menu item when there are no sub-items

Added by Nevik Rehnel almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Minor
Assignee:
-
Category:
-
Target version:
-
Start date:
September 29, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

The "Services" main menu item is being displayed even if there are no items in it.
In a default Audacious install (3.3.2 on a Xubuntu 12.04 in my case), the "CD menu items" will be enabled from the start, and it provides the only sub-items for the "Services" menu at that time. When you disable the plugin, the items directly provided by it rightly disappear, but the containing menu does not, even though it is now empty.
It will always appear even on subsequent starts, still being empty (the behaviour is not buggy in that sense).

It would be nice if that item (and possibly other menus to which this could happen) were hidden when theyre empty.

History

#1 Updated by John Lindgren almost 7 years ago

  • Status changed from New to Closed

Duplicate of #73.

Also available in: Atom PDF