Project

General

Profile

Bug #258

scrobbler2: Segmentation fault

Added by Thomas Lange over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Major
Category:
plugins/scrobbler2
Target version:
Start date:
February 24, 2013
Due date:
% Done:

100%

Estimated time:
Affects version:

Description

If the new scrobbler2 plugin is enabled, I get randomly segfaults.
I did nothing except enabling it and playing some audio files.

A backtrace is attached.

backtrace.log (1 KB) backtrace.log Thomas Lange, February 24, 2013 00:56
backtrace_full.log (2.2 KB) backtrace_full.log Thomas Lange, February 24, 2013 11:23

History

#1 Updated by Luís Picciochi over 7 years ago

You're playing tracks without having associated the plugin with a last.fm account, is that it?

Can you show the title of a track where that happens?

#2 Updated by Luís Picciochi over 7 years ago

OK, I think I got it: did you set a track playing and then select another one while the first was still playing, without pausing or stopping it?
If so, I was able to reproduce this on my machine. Audacious doesn't call the "ended" or "stopped" hooks on such cases. I can workaround this but maybe the core should be calling one of those hooks.

#3 Updated by Thomas Lange over 7 years ago

You are right, I have not configured a Last.fm account.
But I still don't understand how to reproduce it. For me it happens randomly.
So how do you select another track while the first one is still playing?

#4 Updated by Luís Picciochi over 7 years ago

Here's how to reproduce:
  1. Play track A;
  2. Without pressing pause or stop, play track B;
  3. When the track reaches a "scrobbable" state (i.e., half of it has played or 4 minutes have passed, whichever comes first), Audacious segfaults.

This happens because on step 2 the plugin didn't receive an "end" or "stop" signal.

#5 Updated by Thomas Lange over 7 years ago

  • Assignee set to Luís Picciochi

#6 Updated by John Lindgren over 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Affects version 3.4-alpha1 added
  • Affects version deleted (3.4)

Also available in: Atom PDF