Project

General

Profile

Feature #33

Switch tabs with CTRL-PageUp/Down in Plugins preferences window

Added by Jacopo Lorenzetti over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
-
Start date:
January 05, 2012
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Changing the active tab by pressing CTRL-PageUp and CTRL-PageDown is an expected behaviour common in browsers, file managers and in the Audacious playlist itself.

I think it would be consistent to implement this behaviour in the Plugins preferences window too.

History

#1 Updated by John Lindgren over 8 years ago

  • Status changed from New to Rejected

The "expected behavior" argument is worthless in this case. Just to give you an idea, here are some different behaviors from various programs, old and new:

1. In old DOS programs (Turbo C comes to mind) and older versions of Word, CONTROL+PAGE UP and CONTROL+PAGE DOWN move the cursor to the beginning and end of a document.
2. In newer versions of Word, they move the cursor up and down by actual (printed) pages.
3. In older versions of OpenOffice, they are used to reorder paragraphs.
4. In newer versions of OpenOffice, they move the cursor up and down by paragraphs.
5. In UltraEdit, they scroll the window up and down by screen "pages" (the amount of text visible onscreen) without moving the cursor.
6. In Windows Explorer, Thunar, and Audacious, they move the keyboard focus (the dotted rectangle) up and down by "screen" pages without changing the selection (the blue highlighting).
7. In Firefox, as you mentioned, they switch tabs.

We already have CONTROL+TAB and SHIFT+CONTROL+TAB for switching playlists. These combinations mimic the ALT-TAB and SHIFT-ALT-TAB used to switch application windows on most desktops. Long ago (think Windows 3.1) they were used to switch between document or "child" windows within a single application window. More recently, they are used in web browsers to switch tabs, and so it makes sense to use them also in Audacious for switching playlists.

Okay, I'm off my soapbox now. :)

#2 Updated by John Lindgren over 8 years ago

Hmm, I confused this with your next report (#34), but the conclusion applies to the plugin preferences window also: CONTROL-TAB and SHIFT-CONTROL-TAB are the key combinations that should be used.

#3 Updated by Jacopo Lorenzetti over 8 years ago

John Lindgren wrote:

The "expected behavior" argument is worthless in this case. Just to give you an idea, here are some different behaviors from various programs, old and new:

I'd also expect I could load Audacious with the L Shift-O combination like I did on the VIC-20. Is it possible to implement it? :D

Seriously, I confess I didn't know about Control+Tab and Control+Shift+Tab. I also noticed that the Control-Alt-PageUp and Control-Alt-PageDown combinations do work for cycling between tabs everywhere in Audacious. I'll start using one of these.

I called the Control+PageUp/Down combinations 'expected behaviour' because I thought it was the accepted standard in modern tabbed non-wordprocessor applications (it is the HIG recommended accelerator for switching tabs in the GNOME desktop and in the KDE desktop, it works in GNOME dialog boxes and tabbed applications like Nautilus or GNOME Terminal, it works in KDE tabbed applications like Kommander, it works in tabbed web browsers like Chromium, Firefox, Ephiphany or Konqueror, it works in Windows dialog boxes and tabbed applications like Excel, etc).

I didn't know it isn't so universally accepted in some applications, but it's not a big problem after all.

Also available in: Atom PDF