Project

General

Profile

Bug #564

Stream pausing is broken

Added by Artem S. Tashkinov about 5 years ago. Updated 2 days ago.

Status:
Rejected
Priority:
Major
Assignee:
-
Category:
core
Target version:
Start date:
August 06, 2015
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

This bug is actually ages old and even XMMS had it.

So, the problem is when you hit "pause" and then hit resume, then in some cases Audacious will resume the stream or switch to the next track in a playlist.

There are two ways to deal with this issue:

1) When the user hits "Pause" Auadacity will continue reading the stream to a buffer and then play it on resume. This is actually bad for many reasons: a) the user may leave his PC for hours or even days, and Audacity will consume all the RAM and crash consequently b) the user may expect no traffic in case of "Pause" and such a behaviour is irrational and detrimental.

2) So, the best way to resume the stream will be to reset it.

History

#1 Updated by John Lindgren about 5 years ago

  • Status changed from New to Rejected

Pause is explicitly intended not to reset the stream. If you want to reset the stream, use Stop instead. Not a bug.

#2 Updated by Artem S. Tashkinov about 5 years ago

I say that "pause" for streams does not work in Audacious at all, you say the user shouldn't press this button?

I smell some kind of brokenness here.

Maybe you should disable "pause" for streams altogether.

#3 Updated by John Lindgren about 5 years ago

Pause works fine for short periods of time, which is all it's intended for. We're not going to disable features just because some users abuse them.

#4 Updated by Artem S. Tashkinov about 5 years ago

John Lindgren wrote:

Pause works fine for short periods of time, which is all it's intended for. We're not going to disable features just because some users abuse them.

How difficult is to try to restart the stream instead of jumping to the next playlist entry whenever the user paused for too long?

This is what this bug is about. Nothing more, nothing less.

#5 Updated by Bukaj Sytlos 2 days ago

I would like to revive this issue as I think it is really an issue.
Normal workflow is to pause and not stop. Even in integration with KDE music control you have play/pause, next/previous.
As Artem said, audacious should try to restart the stream if it cannot continue after pause and not jump around the playlist.

Thanks in advance to take this into consideration

Also available in: Atom PDF