Project

General

Profile

Bug #590

Window positions changing unpredictably after update to 3.7

Added by Marcin Kocur almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Minor
Assignee:
-
Category:
plugins/skins
Target version:
-
Start date:
November 17, 2015
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

Hello,

after upgrading to 3.7:
[2015-11-13 22:42] [ALPM] upgraded audacious-plugins (3.6.2-2 -> 3.7-1)
[2015-11-13 22:42] [ALPM] upgraded audacious (3.6.2-1 -> 3.7-1)

I can see that playlist and equalizer in GTK winamp like interface are changing positions for values like 50px in totally unpredictable way so one overlays or stands out of another. It happens after closing audacious to tray icon, changing song and redisplaying audacious back.

I found a workaround: simply rename playlist-state file.

That was how the old file looked like: http://wklej.org/id/1846311/
And the new file recreated by audacious: http://wklej.org/id/1846312/

However, when I tried to simulate this problem in order to make a screenshot, I found another issue. I just messed up audacious windows as it is on the screen in attachement. Then I repeated what I wrote above: minimized to icon, changed some songs, reverted back: audacious's windows were messed again in different way.

This may not be an upgrade issue, this may exist since some time. I'm using xfce with composition manager enabled.

aud.png (64.8 KB) aud.png Marcin Kocur, November 17, 2015 14:37
aud.png (28.3 KB) aud.png Marcin Kocur, November 19, 2015 08:57
aud2.png (25.5 KB) aud2.png Marcin Kocur, November 19, 2015 08:57

History

#1 Updated by John Lindgren almost 4 years ago

This is generally a window manager issue, as stated on the website (http://audacious-media-player.org/problems). It's very unlikely to be related to the playlist-state since there is nothing in that file that controls window size or placement. XFWM has some "tweaks", one of which (if I remember correctly) allows you to disable "smart" window placement. Try doing that.

#2 Updated by John Lindgren almost 4 years ago

Also you can try running OpenBox instead as a test; if that fixes the problem, then it's definitely related to XFWM4.

#3 Updated by John Lindgren almost 4 years ago

  • Category changed from plugins/gtkui to plugins/skins

#4 Updated by Marcin Kocur almost 4 years ago

I installed openbox with tint2 to see tray icon. There is the same problem. To reproduce: put audacious to right bottom edge of screen, minimize it to tray icon, using keyboard shortcuts play next song, play previous song, reopen audacious from the icon.

On the second screen I moved tint2 to some other edge of screen so it would not interfere with audacious window but effect is the same.

#5 Updated by John Lindgren almost 4 years ago

  • Status changed from New to Rejected

The problem is that you are moving Audacious to a place where it overlaps with the panel. The window manager is "fixing" it for you and moving some of the windows where they don't overlap. There's nothing we can fix here; it's a window manager "feature".

#6 Updated by Marcin Kocur almost 4 years ago

It could be true for aud.png but not for aud2.png. There is nothing around audacious except of screen edges.

#7 Updated by John Lindgren almost 4 years ago

Marcin Kocur wrote:

It could be true for aud.png but not for aud2.png. There is nothing around audacious except of screen edges.

You haven't given exact scenario details, but the spacing is clearly the same as was reserved for the panel in the other screenshot. Look into how your panel and window manager communicate with regard to screen edge struts; there may be a bug somewhere in the panel or the window manager (or it could simply be a protocol limitation). Regardless, it is the window manager moving the windows, not Audacious. So you be discussing this with the developers of your window manager, not here.

Also available in: Atom PDF