Project

General

Profile

Bug #689

Error dialog at end of certain m4a/aac tracks

Added by Will F. about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Major
Assignee:
-
Category:
-
Target version:
-
Start date:
December 18, 2016
Due date:
% Done:

0%

Estimated time:
Affects version:

Description

I'm seeing an error dialog which ends in "Unknown playback error (check the console for detailed error inform" when certain m4a audio reaches the end. There is no playback error, only these dialogs keep popping up. I have attacked an example of one such file.

sample.m4a (1.34 MB) sample.m4a Will F., December 18, 2016 01:10

History

#1 Updated by Will F. about 2 years ago

And here is the terminal output when this happens.

ERROR ffaudio-core.cc:185 [aac]: <0x7fe52c0837c0> channel element 2.0 is not allocated
ERROR ffaudio-core.cc:214 [log_result]: avcodec_send_packet failed: Invalid data found when processing input
ERROR util.cc:295 [audgui_simple_message]: Error playing file:///home/ergo/sample.m4a:
Unknown playback error (check the console for detailed error information)

#2 Updated by John Lindgren about 2 years ago

  • Status changed from New to Rejected

This is not a bug, the file is malformed. Try re-encoding it, or if it was a digital download, ask for a refund.

WARNING ffaudio-core.cc:185 [aac]: <0x7f145c07c280> Multiple frames in a packet.
ERROR ffaudio-core.cc:185 [aac]: <0x7f145c07c280> Prediction is not allowed in AAC-LC.
ERROR ffaudio-core.cc:214 [log_result]: avcodec_receive_frame failed: Invalid data found when processing input

Also available in: Atom PDF